With Ubuntu studio with 2.6.24-19-rt and 600MB in limits.conf and qjackctl that calls /usr/bin/jackd -R -P60 -t1000 -dfreebob -r44100 -p256 -n3 -D, 1Gb Ram.

I have only one firewire audiocard running with freebob.

Everything works fine with the recording of four track of a song; but at fifth when I push the stop button after a track recording ardour disappears.
Sometimes it generates an xrun, and sometimes not.

Here it’s my ardour.rc file:
(MIDI-port tag=“control” device=“ardour” mode=“duplex” type=“alsa/sequencer”/)
(MIDI-port tag=“mcu” device=“ardour” mode=“duplex” type=“alsa/sequencer”/)
(MIDI-port tag=“seq” device=“ardour” mode=“duplex” type=“alsa/sequencer”/)

(Option name=“trace-midi-input” value=“0”/)
(Option name=“trace-midi-output” value=“0”/)
(Option name=“use-tranzport” value=“0”/)
(Option name=“minimum-disk-io-bytes” value=“262144”/)
(Option name=“track-buffer-seconds” value=“5”/)
(Option name=“disk-choice-space-threshold” value=“57600000”/)
(Option name=“xfade-model” value=“0”/)
(Option name=“auto-xfade” value=“1”/)
(Option name=“destructive-xfade-msecs” value=“20”/)
(Option name=“mute-affects-pre-fader” value=“1”/)
(Option name=“mute-affects-post-fader” value=“1”/)
(Option name=“mute-affects-control-outs” value=“1”/)
(Option name=“mute-affects-main-outs” value=“1”/)
(Option name=“plugins-stop-with-transport” value=“0”/)
(Option name=“stop-recording-on-xrun” value=“1”/)
(Option name=“create-xrun-marker” value=“1”/)
(Option name=“stop-at-session-end” value=“1”/)
(Option name=“quieten-at-speed” value=“1”/)
(Option name=“show-track-meters” value=“1”/)
(Option name=“jack-time-master” value=“0”/)
(Option name=“smpte-format” value=“6”/)
(Option name=“timecode-source-is-synced” value=“1”/)
(Option name=“no-new-session-dialog” value=“0”/)
(Option name=“use-vst” value=“1”/)
(Option name=“periodic-safety-backups” value=“1”/)
(Option name=“periodic-safety-backup-interval” value=“120”/)
(Option name=“default-narrow_ms” value=“0”/)
(Option name=“font-scale” value=“102400”/)

(RulerVisibility smpte=“yes” bbt=“yes” frames=“no” minsec=“no” tempo=“yes” meter=“yes” marker=“yes” rangemarker=“no” transportmarker=“yes” cdmarker=“no”/)
(Keyboard edit-button=“3” edit-modifier=“4” delete-button=“3” delete-modifier=“1” snap-modifier=“32”/)
(TransportControllables roll=“0” stop=“1” goto_start=“2” goto_end=“3” auto_loop=“4” play_selection=“5” rec=“6” shuttle=“7”/)

(Protocol name=“Generic MIDI” active=“no”/)
(Protocol name=“Mackie” active=“no”/)

Here it is how I run ardour:

Ardour/GTK 2.5
(built using 3525 and GCC version 4.2.3 (Ubuntu 4.2.3-2ubuntu7))

loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/darkad/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/darkad/.ardour2/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
ardour: [INFO]: looking for control protocols in /home/darkad/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [INFO]: Control surface protocol discovered: “Generic MIDI”
ardour: [INFO]: Control surface protocol discovered: “Mackie”
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property GtkWidget::cursor-color' of typeGdkColor’ from rc file value “((GString*) 0x8bdbb30)” of type GString' loading bindings from /home/darkad/.ardour2/ardour.bindings Loading session /home/darkad/art/registrazioni/prison/prison using snapshot prison (1) Loading history from '/home/darkad/art/registrazioni/prison/prison/prison.history'. Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve propertyGtkWidget::cursor-color’ of type GdkColor' from rc file value "((GString*) 0x9194310)" of typeGString’

here it is a log window that i see when i run ardour:

[error] no devices found for driver alsa.

If I create a new song (session) and I record a new track I can record and listen what I recorded.

I had this problem with ardour 2.3 and I still have it with ardour 2.5.

Any suggestion?

I solved exporting the tracks in a new session and now it works.