Dante Virtual Souncard issue

I’m having an issue with Ardour 6.6.0 using Dante Virtual Soundcard in ASIO mode

this is a brand new machine:
16GB Ram
Windows Workstation 20H2

When I start a Ardour session I get a lot of xruns and the audio is stuttering
is there some way to fix this?

Thank you

What settings? The basic thing to try if having trouble is reduce the number of channels configured, and increase the latency. Also increase the buffer size in the ASIO settings.

I’m using 2 IN - 2 OUT
48 Khz 2048 Samples

in the DVS Asio Setting I setup 2048 Samples

That seems pretty optimal for settings. Have you tried any other software to try to isolate whether it is a system problem, or an Ardour problem?
My primary system is Linux, so I am a lot more familiar with the performance tuning there. There are some settings which may be possible to try in windows, for example using task manager to change Ardour to realtime priority (if it is not already, Ardour can use realtime scheduling itself in Linux, but I am not sure what the capabilities are on Windows).

REAPER in the same condition works fine

Have you tried using “Buffered I/O” (option in the audio/midi setup window)?

Also Ardour 6.6.142 (or later) available from https://nightly.ardour.org may help due to the following change:

Alternatively ASIO4All can work apparently work around this.

I don’t think that is an option in this case, Dante Virtual Soundcard has only ASIO drivers, no WDM driver available.

Try 512 for the buffer size, not 2048. Going off memory Dante is VERY picky about that, which makes sense considering you can set dante to .5mS latency round trip or lower.


Dante Virtual Soundcard support WDM
but with 16 in 16 out and much more latency

any kind of buffer size do not solve the problem

The virtual sound card has separate settings for Dante buffer size (shown as latency in the Dante settings) and ASIO buffer size. I think that indicates that the driver has extra buffering so that the application can only be called ever 2048 samples to refill the buffer, but the kernel driver will break that down into multiple smaller buffers to put in the network packets.

Does Ardour request realtime scheduling on Windows like it does on Linux?

Yes, it does using pthread-w32 which uses SetThreadPriority() under the hood.

Some update about this topic

I’ve been testing severeal system, with different CPU and memory settings
last system is an HPZ4 based on a Core i9-10980
32GB of Ram
SSD System drive
Nvidia Quadro RTX 4000

this system should be powerful enough not to have any issues
however I’m experiencing exactly the same problem
it looks that there is some sort of incompatibility between Ardour and the Dante Virtual Soundcard

Anyone there could make a test to confirm this?

I haven’t run it in a while but I have run ardour and Dante on windows with no issues before other than as I mentioned above making sure to set my buffer to 512.

I use Dante and Waves Tracks Live (based on ardour) fairly regularly on Mac OS though.

I think I’ve understood the issue
quite crazy

Here the steps to reproduce:

  1. With a fresh Windows installation
  2. Install DVS and set it up with ASIO, any kind of I/O or buffer
  3. Install Ardour
  4. Run Ardour and create a new session with the DVS ASIO audio device, any kind of buffer
  5. When the session is runnig you will see that xruns are growing constantly
  6. At this point just add an input with a Dante source connected (Dante rx 1)
    xruns will stop growing and will never do it again!
    So, since I was seeing xruns growing I’ve never tried to connect a source…
    It looks that Ardour is having some issue with DVS until it do not receive a source

Interesting information, I would say

That makes perfect sense. The dante virtual device does not have it’s own clock source and relies on getting it from the network. If you have a dante network with only one device, that device is the network master clock. until you connect to it, the DVS has no clock and xruns are expected. Someone with better dante knowledge could likely be more specific.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.