Crossfades in 3.0

Hi there. I’m using Ardour 3.0 on Ubuntu Studio 12.10. I have just started using it, and have almost immediately hit a problem, which is that it refuses to create crossfades. I understand the crossfade system is a little different now, but I can’t figure out how to make it work at all. Any suggestions would be greatly appreciated!

it is. creating them, but they do not span the overlap anymore. one day soon there will be a write up in the manual about this. and after that, the option to make them span the overlap may return, at least when first created. meanwhile, zoom way in near the start of the region overlap and you will see them, or just drag the handle for the xfade to stretch it out.

EDIT: Fixed a tag so that most of the post is actually visible:) /Seablade

If you have 2 regions. Move them so they overlap each other. If that’s done move you mouse to the top of the the region,
you will see squares. Move the square that above the section where they overlap and drag it to the point where the fades must end.
You will see in the overlapped section in X from the crossfade. If you right click the mouse, you will have some options for the style of crossfading.
Linear, symmetric, slow, fast, etc.

When I first used Ardour 2 I thought the fade-in and fade-out controls at the end of a region would work as cross-fades when the region overlapped another, and was disappointed to discover they didn’t.

I am therefore delighted now that Arour 3 DOES work that way - one of my favorite enhancements (and only added quite late in the development of A3, I believe)

Brilliant. Thanks so much, all. Ardour 3 is great!

I noticed this a while ago and thought it was just something weird going on with my set up. Fairly disappointed to find out that this is how it is meant to be because one of the reasons I loved ardour was the ease and fluidity of making new crossfades.

Please note that there IS a crossfade there, just like before. But by default it is very short. For 99% of the time this is all you wanted anyway. If you want to stretch the crossfade a little longer, there are key commands to do that.

This video shows the basic operation (the video is for Mixbus, but A3 works this way now):

setting an automatic x-fade option?

is it possible to return the old behaviour, where the crossfade is automatically created for the duration of overlap? in the video above this can be set in the menu Options, but that menu doesn’t exist in Ardour 3. where can this be set?

@novaviator: not possible at thsi time. it will be added back.

I tried to find the answer elsewhere but this thread kept cropping up so I decided to comment here instead of looking for a more recent one or starting another, even though we’re on A4 now. This so that other folks could find the answer quickly. It may not have been the wisest decision but anyway…

Has the automatic duration feature been added back now or is it no longer needed?

The closest alternative method I use is to first overlap the two regions and then drag the fade on the top one until it reaches the end of the overlapping part. For accuracy I enable the grid before doing this.

I don’t know if this is the fastest way of doing the equivalent of putting a region on top of another with automatic crossfading in Ardour 2.


I am disappointed that the automatic crossfade for overlapping regions no longer exists. I do a lot of minimalist music and the way Ardour 4 does it now is WAY to clunky to use. First, the pasted on region can’t be the one faded for some reason. It just overrides the bottom layer and so a dip in sound happens. With what I do, the original crossfade worked perfectly. Now, I have to select things several times to do what I could do automatically before.

I also duplicate several tracks at the same time and now I have to finagle my way around those duplicated regions back and forth to try to get a crossfade going. I also have to layer them properly. This causes me to do a lot of reclicking around that I didn’t have to do before. It is just too much of a hassle. So, I went back to Ardour 2 for now. It works great for what I want to do.

I also went back for several other reasons namely the new graphics on the interface are way to difficult to deal with now. There is just too many objects making a lot of the lettering and buttons too small to see or click on. Also, the editing of text doesn’t show the cursor hardly at all and I can’t tell where in the text I am typing until I make a mistake and have to redo it all over again. Also, I can’t tell as well what is going on. Before, certain things would blink, or be colored differently, etc. Now, it is too sublime.