Creating an Application Bundle on Linux

I’ve built/ran master succesfully on Linux
and wanted to create an application bundle to run Ardour on my ‘studio’ computer.

Following the steps from here

cd tools/linux_packaging
./build --public --strip some
./package --public --singlearch

When running the second command, I get the following error:
cp: cannot stat '../../build/gtk2_ardour/ardour-6.0.pre1.143*': No such file or directory
and indeed ardour-6.0.pre1.143* does not exist in gtk2_ardour folder.
So the final package is also failing because it searches for ardour-6.0.pre1.143

In the gtk2_ardour is however an ardour-6.0.pre0.3579 file

So I wonder what I’m doing wrong,
thanks for any help.

It looks like you did a ‘git pull’ after you had compiled ardour-6.0.pre0.3579 and before you tried the packaging.
If so you have the pre0 binaries but the source is pre1 and expects pre1 binaries as well.

1 Like

I’ve ‘cleaned’ and recompiled again and now it works.
Thanks for your help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.