Crash when switch between snapshots (Ardour 6.2 )

Hi
when i switch between new snapshot to pre snapshot ardour not responding
and going out from program

I had this happen on old Ardour 5.12. If this is still the same bug, then the workaround is to always quit Ardour when changing sessions / snapshots and start Ardour again.

@mhartzel: The old bug was fixed (the issue was that you if you accidentally double-clicked, it was possible to load the snapshot twice, in short succession. Some asynchronous engine work stumbled over itself and crashed or deadlocked)

There is some anecdotal evidence that this can also happen when loading a different session (snapshot or otherwise) from a running Ardour instance if you’re using JACK.

When you run Ardour from the commandline, can you check if there’s a message

Failed to register port "<NAME>", reason is unknown from here

right before the crash?

1 Like

Hi Robin

when i run command line & switch to old snapshot ardour crashed and display below error

Graph::drop_threads() sema-counts: 0, 0, 1
Carla assertion failure: “childPID == 0” in file threads/ChildProcess.cpp, line 154, value 3263
JUCE Assertion failure in juce_Thread.cpp:43

Does this work in sessions where you don’t use Carla as plugin?

yes
this issue depending to use carla-rack in session
tnx