Crackling and Dropouts

Hi there, I already tried in IRC this morning, but I had to leave.

When I playback for example a stereo drum track, I jam on another with guitar on it.
As soon as I put Ardour5 in the background it starts to crackle and dropping out the sound.

Project is 48 kHz / 24 Bit / 64 samples buffer. Works with other DAWs, so I want to know, is this Ardour5(.0) or another problem?
OSX 10.11.6.

What does “put ardour in the background” mean, specifically? On Unix systems before (and after) OS X, that has a specific technical meaning but I think you are referring just to window arrangements.

Yes, its “behind” the browser or LO writer.

Please file a bug report about this. Nobody has ever mentioned it before.

Do you want the complete console outputfor the session?

I recognized the DSP value jumps to 80-100 when Ardour is not the active window.

Just a bug report, because otherwise the issue will be forgotten. The forums at are not a bug reporting location, and we don’t review them.


Can you try the steps listed here, but for Ardour instead of ProTools? I am curious if this makes a difference (My money is on yes based on what you have posted but not sure)

It is sad that we are getting to a point that OS X, a system that used to be great for media production because you didn’t have to configure it, is moving in the direction of you have to configure it.


To be fair, he claimed that it “works with other DAWs” … but yes, it would be a good test.

It seems that it may be possible for Ardour to disable this for itself:

Applications may be opted out of App Nap automatically based on their application type. Currently, only applications which can become the frontmost app are eligible. This behavior may change in the future. If you have an application which is LSUIElement or LSBackgroundOnly, you can opt your application in to App Nap by setting the NSSupportsAppNap key in your Info.plist to be a Boolean type with a value of YES. A value of NO is ignored for all applications.
If your application shows a user interface, then the system will use the application visibility and other heuristics to move your application in and out of App Nap automatically. If your app does background work at various times but shows no UI, it can use the User Activities API to inform the system when it is appropriate for it to be eligible for App Nap.

It is also possible for the user to do this in a Terminal window with the following command, though there are many reports of it not working (for other apps):

defaults write org.ardour.Ardour5 LSAppNapIsDisabled -bool YES

This stuff was all added with Mavericks. I never run Ardour in the background, so I’ve never noticed it.

Fixed in git. AppNap is now disabled on OS X/MacOS 10.9 and above (for Ardour).


So did you confirm that appnap was the cause of sonnie’s issues or was this as an extra benefit?


I did not confirm it. I just read up on other applications that have problems when being placed in the background, saw that it was a new feature in 10.9 and moved on from there…

Ok was wondering. Yes my suspicion is that it would cause an issue like described, especially at such low buffer size, but wasn’t 100% sure. Will be interested to hear results from sonnie.


That could be a solution. Will try it later today. :slight_smile:

Just tried it. Unfortunately it was not the problem.

Well in this exact moment the DSP value “raises” to 40 instead of 100%. So I need more time for a correct reply.

It happens in 98% of all my tests. As soon Ardour hits the background the DSP hits the 100% (from < 5-10%) and it starts to crackle and dropout. Even with just one mono audio track without plug-ins.
So it has nothing to do with app nap. But it was worth a try. :slight_smile:

Since this doesn’t happen on my OS X system (El Capitan), it will be essentially impossible to diagnose this issue without you being able to build Ardour yourself. This is unfortunate, but that’s the way it sometimes works (or doesn’t work).

Are you working with JackOSX? I always use CoreAudio. Try surfing several youtube tabs in chrome, just drive the CPU anyhow.