Crackle with US-122

This is actually a jack problem I think, but I haven’t had any responses on the jackit-devel list so I am trying here:

I have successfully used a Tascam US-122 for some years, but today it started producing crackly output when using JACK. I don’t think I have changed any settings since yesterday when it was working fine but obviously I must have missed something. No xruns or other snags are reported by jack, however it does seem to segfault when stopping:

jackd[6890]: segfault at 00000000000003dc rip 0002b35aa410071 rsp 00007fff006a8e90 error 4
My kernel is linux-2.6.21-gentoo on AMD64 so I don't have full realtime, just desktop preemption. This lack has never affected me before, but I am unable to get rt-sources to boot to test further.

Diagnostics thus far:

  • Tascam output is perfectly fine under plain ALSA, so the card isn’t broken.
  • My other sound card in this machine (SB Live) is fine under JACK.
  • I have tried various settings from massively low latency (128 frames) to very high. Under 4 periods at 2048 frames the crackle became a major stutter but otherwise the usual crackle persists.
  • The problem occurs running as root as well as a normal user.
  • The same issue strikes using ardour and audacious with jack output.
Here are some sample jackd parameters and output, however I have also tried the special rawusb device hw:1,2 with the same results:
/usr/bin/jackd -R -P80 -p128 -dalsa -dhw:1 -r44100 -p512 -n3 -i2 -o2 -H

jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver …
apparent rate = 44100
creating alsa driver … hw:1|hw:1|512|3|44100|2|2|hwmon|swmeter|-|32bit
control device hw:1
configuring for 44100Hz, period = 512 frames, buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 3 periods for playback

Can anyone suggest where I might look to resolve this one?

Haven’t tried recording yet, but if you look at the diagnostics list you will see it works fine under direct ALSA.

Is recorded output crackly as well?

I’m just wondering if it might be something ‘lo tech’ like dust or a bad connection somewhere. Sounds almost like something may have come ‘unglued’ in your hardware. If you have access to another US122 it would be interesting to see if you still get the crackle.

Have you tried it under Alsa/OSS (no jack) just to see if it’s any different?