Crackle after turning off the program

I am using Mixbus 32C on AvLinux MXE. When I close the program it apparently doesn’t free the sound card properly because the sound crackles. The only thing that helps is resetting the machine or reconnecting the USB cable to the sound card.

Same thing with Ardour.

I use them in ALSA mode

It is not a known issue, yet the problem is rather re-initialization by whatever controls the soundcard after Ardour releases it. I do not know what recent AVLinux uses… pipewire? @GMaq any hints?

Try to get some diagnostic information: The following script lists all soundcards, their current settings.

Run it 3 times (while playing audio):

  1. before starting ardour (everything works)
  2. while Ardour is running
  3. after exiting Ardour (crackles)

Theoretically the output of the script from (1) and (3) should be identical. If it is not that may provide a clue:

cd /tmp && wget && bash ./

I did the test. Output 1 and 3 are identical. What could be the matter? It seems that the system is not properly release the Mixbus/Ardour ALSA mode back to the Pulseaudio side. Maybe some update has broken something. I tested AvLinux with a live USB session and everything works as it should.

AVL uses the same Pulse/JACK ‘pajackconnect’ bridging that it has for years, I have made no changes to this however there may have been Debian (or MX) updates to jackd2 and PulseAudio along the way. I’m not touching PipeWire until Debian makes it the default which I’d guess will likely be in the next Stable (Bookworm) release… AVL is currently based on Debian 11 (Bullseye)/MX-21.X.

Thanks for chiming in.

I do recall that there were some issues with “pajackconnect” when ardour uses freewheel export. Is that still the case?

I think pajack does not correctly recover once it was suspended. So that may explain the issue.

You may be right about the freewheel (I don’t use it and have not tested recently) however I think the suspend issue was coming back from suspend on a systemd system but MX/AVL uses sysvinit by default although booting their systemd shim is a boot option for those who need systemd. However Mika is not having the issue on the last AVL ISO but it has appeared in the meantime… pajackconnect has not been updated so although it may have some general shortcomings I don’t think it is the culprit here…

@Sojuzstudio are you booting AVL with systemd, or with the default sysvinit?

Good question. Somehow I have managed to miss the Grub menu. It doesn’t show up at all on startup. What have I done to it?

However, I was able to restore the Grub menu easily using MxTools. Yes, this will boot the default sysvins

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.