cracking noise M-Audio-Delta1010 Rack


We have connected the input of the Delta 1010 with a sinus generator.
If we connect the input of the Delta 1010 with a output of the Delta 1010 via envy24control, then we have an absolutly clean
output signal.

But when we recording or monitoring via ardour then we have cracking noises.
We tried to change the samplerate in jack, @ 8kHz the signal was clean, if we incrase the samplerate the distortion increases also (cracking noise)

I hope somebody can help.
thanking you in anticipation


Ubuntu Studio 1010 32 Bit Lenovo ThinkCentre Intel® Core™ i3 CPU 550 @ 3.20GHz Dual Core

Are you running Jack in realtime? And I assume adjusting the buffersize probably makes it go away?


sounds like you’re getting xruns. Try adjusting the buffer size as seablade suggests. My recording rig has a 1010 and is on ubuntu 10.10, although it is just a p4 2ghz single core chip with 1.5GB of ram, and I get xruns for any buffer size under 128, but really, ~5ms is incredibly low latency, so you probably won’t be able to hear it.


There are no xruns reported at the jack log window.
I have changed the buffer size, but no better sound quality.

At m-audio forum i got the answer, disable the powermanagement (speedstep) are not enough
for correct work. In my Bios i can only disable the CPU speedstep.

m-audio forum message:

I heard there is a linux-software that enables more options for CPU-setup.

Do you have further ideas?

Thanking you in anticipation

I heard there is a linux-software that enables more options for CPU-setup.
I think what you are looking for is the cpufrequtils package. Assuming your hardware and kernel support it, this enables to to set your CPU speed or to set up a governor that adjusts the speed automatically according to load. Anahata

IRQ sharing with Delta1010 can also create ‘ALSA xruns’ that JACK might not see, but you will definitely hear. I’ve had that issue; an nVidia video card and a Delta 1010 that shared the actual hardware INT line and that could not be changed on that hardware. The stock way to get them off of the same INT (distinct from IRQ; I’m talking about the physical PCI ‘INT’ line) is to move the Delta1010 to another slot.

See the output of

cat /proc/interrupts

and make sure the ICE1712 device is not sharing with any other device; if it is, you might be seeing this issue.

i had similar problems with a delta 1010 when i recently upgraded motherboard and OS to kxstudio/ubuntu10.04. i had an old PCI graphics card sharing the bus with the delta 1010 card (which, by the way, worked nicely for years on an older motherboard running 64studio). i finally went out and got a cheap PCIe graphics card to get it off the PCI bus and everything started working great. i suppose there must be a workable IRQ configuration but, for me, it was well worth the $20 to make the problems just go away.