cpufreq-info

Hi,

Just installed ADOUR on Linux ROSA Fresh ( Forked from Mandriva )

I have message our system seems to use frequency scaling.
This can have a serious impact on audio latency.

I have seen other threads on this, but my OS I doubt anyone users here and Kernel is different.

Could someone have a peek at the following and give some feedback ? please

dx dx # cpufreq-info
cpufrequtils 008: cpufreq-info © Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 0.97 ms.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency is 2.40 GHz (asserted by call to hardware).
analyzing CPU 1:
driver: intel_pstate
CPUs which run at the same hardware frequency: 1
CPUs which need to have their frequency coordinated by software: 1
maximum transition latency: 0.97 ms.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency is 2.40 GHz (asserted by call to hardware).
analyzing CPU 2:
driver: intel_pstate
CPUs which run at the same hardware frequency: 2
CPUs which need to have their frequency coordinated by software: 2
maximum transition latency: 0.97 ms.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency is 2.40 GHz (asserted by call to hardware).
analyzing CPU 3:
driver: intel_pstate
CPUs which run at the same hardware frequency: 3
CPUs which need to have their frequency coordinated by software: 3
maximum transition latency: 0.97 ms.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency is 2.02 GHz (asserted by call to hardware).
dx dx #

How is that looking ?

Thanks

It isn’t looking good from an audio perspective.
You’re using the “powersave” governor (“The governor “powersave” may decide which speed to use
within this range”) when you should be using the “performance” one instead.

Run cpupower -c all frequency-set -g performance as root.

I have had a look and if I am correct , I will need to change this in the conf file.

dx@dx ~ $ urpmi cpupower perf
Packages perf-4.9.95-2-rosa2016.1.x86_64, cpupower-4.9.95-2-rosa2016.1.x86_64 are already installed
dx@dx ~ $ cpupower
Usage: cpupower [-d|–debug] [-c|–cpu cpulist ] []
Supported commands are:
frequency-info
frequency-set
idle-info
idle-set
set
info
monitor
help

Not all commands can make use of the -c cpulist option.

Use 'cpupower help ’ for getting help for above commands.
dx@dx ~ $ cpupower frequency-info
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: Cannot determine or is not supported.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency: Unable to call hardware
current CPU frequency: 2.45 GHz (asserted by call to kernel)
boost state support:
Supported: yes
Active: yes

dx@dx ~ $ cpupower frequency-set -g powersave
Subcommand frequency-set needs root privileges
dx@dx ~ $ su
Password:
dx dx # cpupower frequency-set -g powersave
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
dx dx # cpupower frequency-info
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: Cannot determine or is not supported.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “powersave” may decide which speed to use
within this range.
current CPU frequency: 2.49 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes

dx dx # sudo nano /etc/sysconfig/cpupower

If you would like to use a particular CPU frequency scaling governor

rather than the default one, specify it here.

CPUPOWER_GOVERNOR=

Other command-line arguments to cpupower.

See ‘cpupower help’ and cpupower(1) for more info.

CPUPOWER_OTHER_ARGS=

SCREEN SHOTS OF TERMINAL

Do you think that would be correct

If you would like to use a particular CPU frequency scaling governor

rather than the default one, specify it here.

CPUPOWER_GOVERNOR=PERFORMANCE

Other command-line arguments to cpupower.

See ‘cpupower help’ and cpupower(1) for more info.

CPUPOWER_OTHER_ARGS=

I added PERFORMACE AFTER GOVERNOR=

The command you want to run before doing audio is cpupower frequency-set -g performance , not powersave.

You could remove the # in front of CPUPOWER_GOVERNOR= and add performance after the equal sign but that would mean that you’re always running in performance mode and that’s not necessary for your every day computer use.

The /etc/sysconfig/cpupower line is probably case-sensitive, so you should type performance and not PERFORMANCE.

But unless you’re only using that computer for audio work and for nothing else I suggest you run the command instead.
Running in performance mode when doing word processing, writing an email or checking out some web pages is a waste of cpu cycles and energy.

dx dx # sudo cat /sys/kernel/debug/dri/0/i915_ring_freq_table
GPU freq (MHz) Effective CPU freq (MHz) Effective Ring freq (MHz)
450 0 1600
500 0 1600
550 0 1600
600 0 1600
650 0 1600
700 0 1600
750 0 1600
800 0 1600
850 0 1700
900 0 1800
950 0 1900

Does this look better

dx dx # cpupower frequency-info
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: Cannot determine or is not supported.
hardware limits: 500 MHz - 3.00 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 500 MHz and 3.00 GHz.
The governor “performance” may decide which speed to use
within this range.
current CPU frequency: 2.40 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes

??

I don’t think you have to fiddle with the GPU settings because I don’t think Ardour is that graphics intensive.
But if Ardour is using a lot of CPU you can try and set the GPU max frequency to something low, like 550, and see if you can get some extra CPU cycles available.

Yes, now you’re running in performance mode.

Ok, thanks. I have 16Gig RAM to play with so see what happens.
Thanks for help

Do you have dropouts or x-runs? A lot of modern CPUs do switch frequencies quickly enough. If you don’t have any issues, don’t bother, but if you do have drop-outs, disabling frequency scaling is the first thing to check. – The main issues is that low average CPU usage (not per core) may hold things down.

PS. RAM has nothing to do with this. Ardour itself needs very little. Some sampler plugins may consume RAM (loading huge sample libs into memory).

see also http://manual.ardour.org/setting-up-your-system/the-right-computer-system-for-digital-audio/