CPU Governor - ! WARNING ! - Your system seems to use frequency scaling

Hello, now i found a gui (called cpupower-gui) for that message, who comes on installing Ardour

"!!! WARNING !!! - Your system seems to use frequency scaling"

Is that warning still up to date in Linux Mint 21 Cinnamon? I mean, linux is developed day by day, may be the “Schedutil” Option in the Governor makes all right…?

If still the warning right, what should i set here? Performance of all CPU maximum? Min freq maximum?

And after closing Ardour back to this default setting?

Bildschirmfoto vom 2022-11-12 20-04-11

Ardour is also developed day by day, it’s only a warning and it’s there for a reason.

You may very well be able to use Ardour without problems with the Schedutil governor but if you experience xruns one way to try and mitigate it is to use the Performance setting.

It has nothing to do with the Linux distro but the actual hardware: CPU (and motherboard chip-set) power saving.

Some modern systems can switch CPU frequency fast enough when Ardour and/or some plugins need more CPU. However in many cases a system might stay long enough in low power mode, and switching takes enough time for there to be an audio dropout.

If you get audio dropouts (buffer under/overruns aka x-runs), CPU freq scaling is the first thing to check: In general it is recommended to use the “performance” governor. but the only way to know is to test it on your system.

@stefan-franz

In reading several of your posts here as a new User almost all of your issues could have been avoided by simply using a Linux Distribution designed and intended for Audio work. Linux Mint is popular, extremely attractive and one the best ‘general’ Linux Desktop Distributions out there, it is very much lacking in features needed for Professional Audio production though.

Something like Ubuntu Studio, LibraziK or AV Linux would have had you recording within minutes and have all of these questions answered before you knew to ask them… It is not a trivial thing to set up a Linux System for Audio and Video work as you are quickly learning…

If you are serious about Audio Production perhaps a dual-boot would give you the best of both worlds…

1 Like

Prior to using AVLinux, I had a script that I would run to ready my system, and part was setting the governor.

sudo cpufreq-set -c 0 -g performance
sudo cpufreq-set -c 1 -g performance
sudo cpufreq-set -c 2 -g performance
sudo cpufreq-set -c 3 -g performance

would set each of the cores (I have a 4-core AMD).

Then you can display the current settings using cpufreq-info -o :slight_smile:

$ cpufreq-info -o
          minimum CPU frequency  -  maximum CPU frequency  -  governor
CPU  0      1000000 kHz ( 50 %)  -    2000000 kHz (100 %)  -  performance
CPU  1      1000000 kHz ( 50 %)  -    2000000 kHz (100 %)  -  performance
CPU  2      1000000 kHz ( 50 %)  -    2000000 kHz (100 %)  -  performance
CPU  3      1000000 kHz ( 50 %)  -    2000000 kHz (100 %)  -  performance

@GMaq
Thank you for your tip.
Now it is my first way to try out Ardour (coming from Cubase) and learn the basics. Mint is installed on all of my desks and laptops (11 Devices). And so the easiest way for me was, to try it out.

My main business is selling products and after a working day, i wanted to play some Piano on my studio desk or arrange a few things that I include as a DJ in my live show. Just for fun.

One of my goals is also, to learn more about linux and support the opensource studio software, becaus i want 100% away from Windows.

Linux / or Adour gets as more fas it’s linux gets more fans faster, the easier it is to use and install.
So, if i first need a new Linux system to install Ardour - that is not easy and plug and play…
With my questions here and your answer i learned some basics.

What speaks against it that in the manual or ardour the cpupower-gui would be mentioned as solution for the Installaion message from Ardour? That is an easy solution and it’s easy for everyone to understand. And downloadable from the application management.

Bildschirmfoto vom 2022-11-12 20-04-35

@ardourwlk
Thank you for your setting. I made it with my GUI with success: My studio desktop is 8 core i7 processor - nearly the best machine in 2016 who was able to buy. And i saw with ardour that the dsp value with some plugins gets to 100%. The reason was exactly the governor: It was set as “powersave”. I switched to “performance” (only this to options are on this device) and the DSP value comes down to 20-30%. (of course that was hungry dsp, i found another guitar rack dsp who needs less power. But the governor settings ober the GUI is fine and was for me the solution. I think, it should in the manual. Otherwise some new users mean, ardour has a bad performance…and don’t work with it.
Thanks for your help and i wish an nice sunday.
Greetings, Stefan

1 Like