Cpu, clicks pops, audio issues

hi, i had a moderate amount of synths and plugin chains, went for a Vital pad and dsp is at 100 and audio destroyed. I was on Jack for audio system, so switched to Pulse and buffer way up to 2048 eek, which does not click and pop but dsp is still at 100.
Then had a look at system monitor and I’m using 12% of cpu and little ram. I’m on a new i9 with 64gb ram. How to fix? thanks.

It may happens with some patches. Freeze the track, so you have just audio.

Intel clock rate management? You might want to try activating the “performance” gouvernor instead of the default “powersave” when working with audio.

The Pulseaudio backend should only be used as a last resort one.

Do you have realtime scheduling enabled?
Run ulimit -r in a terminal window; if it doesn’t report something like 90 or higher you’ll have to enable it using the info here

Once that’s done you should enable realtime support in JACK, which can be done in QJackCtl by clicking Setup and enabling it on the Settings tab.


Check this script out:

“rtcqs is a Python utility to analyze your system and detect possible bottlenecks that could have a negative impact on the performance of your system when working with Linux audio. It is heavily inspired by raboof’s excellent realtimeconfigquickscan script.”

To make things easier try to install it from your package manager, depending on your distribution. It won’t make a miracle but it helped me to improve performance a little bit. Hope it helps.

I second this recommendation: rtcqs not only detects potential issues with the different bits of my system’s audio configuration, but when I flags such issues, it offers a URL to curated, up-to-date rationale documents at

E.g., if I flip the CPU frequency scaling governor back from performance to the default ondemand via

$ sudo cpufreq-set -g ondemand

and then run rtqcs, I get the following super-useful warning:

CPU Frequency Scaling

[ WARNING ] The scaling governor of one or more CPUs is not set to ‘performance’. You can set the scaling governor to ‘performance’ with ‘cpupower frequency-set -g performance’ or ‘cpufreq-set -r -g performance’ (Debian/Ubuntu). See also System configuration [Linux-Sound]

1 Like