Controlling Play via MIDI CC

Hello. I would like to send MIDI CC to Ardour to control the PLAY function. I will arm the track(s) and press the red REC button manually, then from my audio interface I will send MIDI CC Control to activate the PlAY button which then would begin recording. I would press the button on my interface again to stop recording so it would activate the STOP button. Is this even possible? If so, what would be the steps? I have tried the information here: The Ardour Manual - Generic MIDI Learn but it does not seem to work out. The audio interface is a RodeCaster Duo but I don’t see how that would matter since the MIDI CC is standardized. This exact scenario works fine in OBS Studio for instance so I would think it might work in Ardour also. I appreciate anyone’s useful input.

Thank you!

  1. Edit > Preferences > Control Surfaces … enable Generic MIDI, then double click on that line to bring up the settings dialog for Generic MIDI. Choose the correct input, ignore all other settings.

  2. Ctrl-middle-click on the play button (Cmd-middle-click on macOS)

  3. Done

MIDI CC are not standardized for the purposes of transport control. There is no MIDI CC message which means “play”.

I did those things but there’s no way to tell Ardour which CC control, channel or on/off value to look for. I realize there’s no standardized value for “Play” but CC codes are standardized. So if I send Control 16 on channel 1 a value of 127 that should be recognized by any midi capable device - no?

You don’t have to tell it, you have to touch/twist/press/click something that sends any MIDI CC or note message to Ardour. Ardour will use the first one it receives from the port you connected.

Note that Generic MIDI control does not handle the more modern “encoders” which do not send continuously varying values but instead send 1 message for “increment” and another for “decrement”. For that, you need to build a binding map by hand.

So the message “Operate Controller Now” comes up at which time I press the button on my RodeCaster to send the command. The message goes away but this still does not work. This is in Windows 10. The protocol settings for the control surface simply states “MIDI function” for the Incoming Midi. On my Linux computer this tells me it is the RodeCaster Duo. Problem there is the middle mouse button doesn’t function on that computer. No big deal I guess. I’ll live without it.

This is the settings dialog for Generic MIDI:

I wrote a midi map and it is working now. In case others would like to use it here it is:

 <?xml version="1.0" encoding="UTF-8"?>
 <ArdourMIDIBindings version="1.0.0" name="RCD MIDI Bindings">
 	<Binding channel="1" note="13" function="transport-roll"/>
 	<Binding channel="1" note="14" function="transport-stop"/>

I have two of the RodeCaster’s smart pads configured to use with this mapping. This is in Windows 10. I have yet to implement it in my Ubuntu installation but will do so soon.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.