Controlling A3 with iPad, iRig MIDI and eyoControl surface?

Has anybody tried it yet? Anybody have any tips & tricks?

I’m running Ubuntu Studio 12.04 with Ardour A3 beta 5.

eyoControl has an awesome DAW controller surface for iPad and I’m hoping it works in Ardour 3.

I have just assembled all the pieces and I’m going to stick it all together and try it tonight.

I’ll be going from iPad => iRig MIDI => Lexicon Lambda MIDI ports => USB => Ardour 3.

The Lexicon Lambda MIDI ports are visible in Ardour 3, that’s all I know for sure right now.

The last Ardour DAW controlling I did was in Ardour 2.8, just doing some faders and what-not through a Casio keyboard that had no transport controls.

Hi Zionhill,

Nice to see I’m not the only one using iPad and Ardour! I’m working in Ardour 2 for effects on live loops going thru Jack and Mobius Looper. Mind blowing fun.

I’m also on OSX, so not much help for your specific questions. I must say, a very cool part to the equation for me is an iOS app I found called MIDI Designer Pro (or MIDI Designer Lite for free trial)
Its really easy to build custom MIDI controls that route to Ardour via wifi on OS X. Limitless options really. I actually emailed the developer a few months back and after a long email thread he helped me get the app working with Ardour.

…I’ve never tried eyoControl…

Anyway, I’m really looking forward to see what happens as more people integrate iPads and Ardour. Keep us posted with your progress.

eyoControl is a no-go!

Even with eyo tech support help no amount or rebooting or configuring could get eyoControl to latch on to the iRig MIDI. I even un-installed all other midi apps on the iPad just to make sure there was no interference.

I purchased Midi Touch and it instantly found the iRig and I could clearly see the red LED out light flashing. I hooked it up to Ardour 3 running in Ubuntu Studio and the MIDI tracer showed the MIDI codes streaming in.

So right now my control chain is: iPad => MIDI Touch app => iRig MIDI => Lexicon Lambda MIDI ports => USB => Ardour 3.

The bad thing about Midi Touch is that you have to create your own Control Surface, but then the good thing about Midi Touch is that you can create your own Control Surface! Midi Touch is $20 in the app store.

Good thing eyoControl was only $6 or I’d really be upset about having to abandon it.

More soon

eyoControl appears to use rtp MIDI. there is no implementation of this for Linux, which is frustrating. routing via the lambda probably fixes this.

other than that, its “just” another Mackie Control device, which means that it can be used with Ardour3 if/when a device-specific file is written for it (it may need no changes from the existing examples, but this is not likely). see the “midi_maps” folder of Ardour3 for existing examples (we support Mackie Control Pro, Nucleus, Behringer BCF in Logic mode and Steinberg CMC devices).

Thanks paul - you 'da man!

Being a programmer by trade I’m fully prepared to customize a map once I get all the pieces in place and look at the output.

I will post it for everyone’s use then