Control Surface

My surface is a Yamaha 01v.
I’ve no trouble with midi learning and I can control faders a muting tracks.
The goal should be to save my configuration in order to use when project is loaded.
But I can’t.
I’ve already check the documentation but no tricks

Ubuntu Studio 14.4 and Ardour 3.5.308


You likely really want to create a binding map…

That way you can just load the binding map in any new session and have it work fine.


Thanks for the answer.

Do not know If I’ve understood.
I have to create a file such as in ~/.config/ardour3/midi_maps ( I suppose have to create that directory by myself …do not know how ardour loads it)
When I use Midi learm (CTRL+ middle) Ardour creates in my project this section :

I just want to control Faders and this is from documentation :

<?xml version="1.0" encoding="UTF-8"?>

How can I join (example) fader 1 of Yamaha to fader 1 of Ardour Mixer ?

Thanks again

Sorry HTML cuts some parts
Protocol name=“Generic MIDI” feedback=“1” feedback-interval=“10000” threshold=“10” binding=“Yamaha 01V bindings” active=“yes”
MIDIControllable id=“116” event=“0xb0” channel=“0” additional=“0x1” feedback=“yes”
MIDIControllable id=“158” event=“0xb0” channel=“0” additional=“0x2” feedback=“yes”

Binding file (*.map) Works fine. Just a coumple of misunderstandings.
Many thanks

Glad you got it working!

first of all: I’m new to Ardour, but I already like it. It’s very inspiring to explore all the possibilities which Ardours adds to making music, so thanks a lot for making such a great piece of open source software.

But I have problem with controlling Ardour over MIDI too; since I installed Ardour 3.5.380 (on a Gentoo system), Ardour reacts strange when I use MIDI learn: In the MIDI Tracer Dialog or with “amidi -d” I can see the controller sends out normal MIDI values (like for instance when moving a fader from “b0 35 00” to “b0 35 7f”), but when “teaching” Ardour to use this hardware fader for anything like track gain or parameters of plug-ins, the value of the controlled parameter doesn’t behave correctly; it jumps a little bit, then ignores the movement of the hardware fader until I move it back to region where it was when I told Ardour to learn, then again only jumps just a bit.
I think this behaviour started after installing Ardour 3.5.380 (the few days I used 3.5.357 it worked well) and adding the lv2 useflag, but wether downgrading to 3.5.357 nor disabling the useflag helped me to get back to the normal behaviour.

Again, thanks for Ardour! It’s super!

PS: Excuse me for my bad english

best bet is to jump onto the irc a nd have a chat with people there where the devs are