Control Surface simple workaround/fix

[ Broken in Ardour 5.x and Ardour 6.x pre-alpha - Linux
reminder: Ardour 6 prealpha – note for my fellow users, do not send bug reports until the developers announce “alpha” stage for user feedback.
Bug is also in Ardour 5, so a bugreport was sent.
This bug must of been around for ages.

Apparently if the user has added control surfaces, and they try to manage the respective midi ports via the “Midi connections” window, they do not get “unbinded” properly if trying to select a unique midi port from the Preferences window.

^ I think this is why a lot of users might tend to get their “midi port input”(the midi port for “note-on” events) to become “locked”. Because a midi port set as a control surface will not be selectable as a midi-port for a midi track’s input.

See these two screenshots,

… I just tested Ardour 6.0.pre0.2488 here with Linux 64-bit, (same thing occurs with Ardour 5)
I can select these two items in the “Midi connections” window.
(selected both “Keystation 88 Midi 1” and “Keystation 88 Midi 2” in this window)

If I now choose either “Keystation 88 Midi 1” or “Keystation 88 Midi 2” from the Preferences/‘control surface’+‘Show protocol settings’, the ‘Midi Connections’ window whether it is closed or open, never reveals an update from the selection from the Preferences window.

However if I choose “Disconnected” from the Preferences window, the “Midi connections” window gets updated showing no selected hardware midi input devices, as shown in the following screenshot.

Essentially the user can lose the ability to send Midi notes to a midi track - as the “pulldown” menu is not updating things appropriately for all places.

^ The user gets confused because if they “enabled” the two “midi ports” via the Midi connections, and then later rely on the Preferences window, – and their setting is “correct” in the Preferences window, --> changing the pulldown option does not disable the previously-set item.

So the workaround here is basically, when setting up the ‘Control surface’, and have already been doing things in the “Midi connections”, the user needs to be aware that if they want to revert back to “one midi port”, they always need to select first the “Disconnected” pulldown option(in the Preferences window) and then choose their preferred midi port from the same pulldown menu.

In quick summarization for clearly putting it:

More than 1 midi port for the same control surface protocol::

–> Use the “Midi connections” Window.

** If the user wants more than 1 midi port for the same surface control protocol, they add more midi ports from the Midi connections window.**

For having only 1 midi port assigned for a control surface protocol::

–> Use the Preferences/Control-surfaces window

** If the user only wants 1 midi port for the same surface control, they need to select “Disconnected”, followed by their preferred midi port from the pulldown menu in the ‘Show protocol settings’ of the Preferences/Control-surfaces window. **

– “Disconnected” needs to be selected by the user on the pulldown menu.
– On dialog-startup chose any “midi port”, then come back to choosing “Disconnected”, then choose the midi port that is the one which is wanted for the binding.
(the default of “Disconnected” already selected is not performing any reset on its own. The user reverting back to it, triggers the reset, and the Midi connections window immediately reveals the update. Any binded Note-on midi ports then become available for midi tracks. << So if you are having an issue which you binded the incorrect Midi port, you now know where the issue is! )

I hope this becomes valuable to some users who are having issues related to the control surface changes. Trying to figure out the correct control surface can be a bit of a challenge, but having a bug like this makes things much more difficult to deal with, so I’m posting this here – the bug has been filed already with the bugtracker.( issuereport )

the bug is a bit benign though is still difficult to overcome as it is not obvious to the user that the midi ports do not get reset from their binding by utilizing the pulldown. If it’s a design feature I wouldn’t be all too around endorsing of such, because it “breaks” the ability of having Midi ports for the midi tracks.

hope this helps


Please make certain bug reports are reported in Mantis, they get lost on forums, whereas in Mantis at least we can keep better track of them.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.