Control surface never connects on startup

This has been this way for a long time in MixBus and is the same in Ardour. Whenever I shut down Ardour or even just close a project, I have to reconnect my control surface. This was the same on my older Mackie control as it is now with my X-touch. The only way I can get it to connect is to turn off the audio driver in the audio/midi window, deselect core midi, start the audio, stop the audio, select core midi then start the audio again. Go to preferences select control surface then reconnect there! This can’t be normal.

It isn’t normal. I have a FaderPort8 and that reliably re-connects (unless I load an old session that didn’t have this ctrl surface) on macOS.

I don’t have an answer

Almost sounds like there are two issues. One with audio/midi setup and one perhaps with MCU ctrl surface saving incorrect connections.

As for the former. Is the device shown in Apple’s “Audio MIDI Setup” app MIDI device list as active? Not greyed-out before you start Ardour: Set up MIDI devices using Audio MIDI Setup on Mac - Apple Support – If so, Ardour should directly pick it up.

One explanation may be that the device is initially not active and only enabled later (hotplug). That way when Ardour starts it is not available and the connection is lost. That does not explain why you have to restart Ardour’s engine though.

Can you try to remove Ardour’s preferences (~/Library/Preferences/Ardour6/config) and start over?