constant crashes in 2.1 AND 2.3

I’m running UbuntuStudio (7.10) on a Dell Precision 340 (1G ram, 2Ghz processor). I’m a novice user of Ardour but familiar with DAW functionality and just recently started tinkering with it to evaluate some tracks we’re cutting with a local producer/eng. I’m not doing anything too ambitious but started playing with some basic LADSPA plugs (TAP Reverb, SC4 compression). Ardour 2.1 which is delivered in UbuStudio crashed very frequently so I thought I’d try 2.3 before posting. I managed to get 2.3 built on my machine (a first for me!) but I still see crashes every 15 to 30 minutes which is unacceptable even for use as a playback tool. I’ve looked for core files but can’t seem to find any. Where is crash data stored? I thought the LADSPA plug ins would be better behaved but they seem to increase the crash rate pretty significantly.

Despite the crashes, I’m excited about Ardour’s robust feature set. It reminds me of when I discovered GIMP for image manipulation. I’m particularly anxious to check out the new percussive onset analysis as I notice this is a critical tool that our producer uses in ProTools. If only I could debug these crashes. Any assistance is appreciated. If there is more specific info needed I’ll provide it if possible. I really want this to work.

@:~$ uname -a
Linux 2.6.22-14-rt #1 SMP PREEMPT RT Tue Feb 12 09:57:10 UTC 2008 i686 GNU/Linux

@:~$ grep MemTotal /proc/meminfo
MemTotal: 1028852 kB

@:~$ grep “model name” /proc/cpuinfo
model name : Intel® Pentium® 4 CPU 2.00GHz

@:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 32G 17G 15G 54% /
varrun 503M 220K 503M 1% /var/run
varlock 503M 0 503M 0% /var/lock
udev 503M 72K 503M 1% /dev
devshm 503M 0 503M 0% /dev/shm
lrm 503M 17M 486M 4% /lib/modules/2.6.22-14-rt/volatile

@:~$ lspci -tv
-[0000:00]-±00.0 Intel Corporation 82850 850 (Tehama) Chipset Host Bridge (MCH)
±01.0-[0000:01]----00.0 nVidia Corporation NV11GL [Quadro2 MXR/EX/Go]
±1e.0-[0000:02]–±07.0 Adaptec AIC-7892A U160/m
| -0c.0 3Com Corporation 3c905C-TX/TX-M [Tornado]
±1f.0 Intel Corporation 82801BA ISA Bridge (LPC)
±1f.1 Intel Corporation 82801BA IDE U100 Controller
±1f.2 Intel Corporation 82801BA/BAM USB Controller #1
±1f.3 Intel Corporation 82801BA/BAM SMBus Controller
±1f.4 Intel Corporation 82801BA/BAM USB Controller #1
-1f.5 Intel Corporation 82801BA/BAM AC’97 Audio Controller

First step, try running Ardour from the command line like this:

(assuming you’re running the version you built yourself)
/usr/local/lib/ardour2 >> ~/ardour.log 2>&1

Then check the file ~/ardour.log to see if it gives you any useful information when it crashes.

Thanks cbreeze, I added the logging params to the exec command in ardour.sh. It seems to be the only way I can get 2.3 to run otherwise I see the following.

@:~$ /usr/local/lib/ardour2/ardour-2.3
/usr/local/lib/ardour2/ardour-2.3: error while loading shared libraries: libardour.so: cannot open shared object file: No such file or directory

but that’s a different matter. I’ll add the path to my environment later unless it’s part of the crashing problem. Anyway, here’s where the session died, seems to be JACK related…

Loading session /home/rgnkjnva/Ardour Sessions/Ride Again Vocal Takes using snapshot Ride Again Vocal Takes (1)
Loading history from ‘/home/rgnkjnva/Ardour Sessions/Ride Again Vocal Takes/Ride Again Vocal Takes.history’.
PluginWindow shown
send show to 2 children of this plugin UI
Send show to 0x9055718
Send show to 0x9083f90
!! send done
PluginWindow hidden
PluginWindow shown
send show to 2 children of this plugin UI
Send show to 0x8cb7be8
Send show to 0x912cba8
!! send done
PluginWindow shown
send show to 2 children of this plugin UI
Send show to 0x9259048
Send show to 0x9374258
!! send done
PluginWindow hidden
jackd watchdog: timeout - killing jackd

Definitely has to do with plug-ins. I found other threads that suggest turning off RealTime and increasing Frames/Period. Mine was set quite low at 64 so I increased it gradually until it’s now 1024 but I still see the same behavior.

I’m an idiot. I meant /usr/local/bin/, not lib. I keep doing that lately (in fact i did it several times last night while starting ardour). Have you tried cranking up jack’s client timeout to 2000ms or more? I won’t be much help beyond that, sorry. Devs?

http://ardour.org/how_to_report_a_bug
http://ardour.org/debugging_ardour

Didn’t have much luck producing a core file however here’s what I did

  1. start a new session
  2. import several wav files (7) into individual audio tracks
  3. add any LADSPA reverb plug-in, pre or post, doesn’t matter. Eventually, Ardour will crash especially with GVerb. However, to really move things along…
  4. add another plug-in, again pre or post, to the same track or a different track. After a few minutes Ardour crashes.

I’ve tried all the LADSPA reverb plugs and a couple others. they all result in a crash particularly when tinkering with plug-in configuration variables. Actually, I’ve found that I can reproduce this crash with an old session that simply has a single bass audio track in combination with LADSPA plugs.

:~/.ardour2$ more ardour.rc
?xml version=“1.0” encoding=“UTF-8”?>
Ardour>
MIDI-port tag=“control” device=“ardour” mode=“duplex” type=“alsa/sequencer”/>
MIDI-port tag=“mcu” device=“ardour” mode=“duplex” type=“alsa/sequencer”/>
MIDI-port tag=“seq” device=“ardour” mode=“duplex” type=“alsa/sequencer”/>
Config>
Option name=“trace-midi-input” value=“0”/>
Option name=“trace-midi-output” value=“0”/>
Option name=“use-tranzport” value=“0”/>
Option name=“minimum-disk-io-bytes” value=“262144”/>
Option name=“track-buffer-seconds” value=“5”/>
Option name=“disk-choice-space-threshold” value=“57600000”/>
Option name=“xfade-model” value=“0”/>
Option name=“auto-xfade” value=“1”/>
Option name=“destructive-xfade-msecs” value=“20”/>
Option name=“mute-affects-pre-fader” value=“1”/>
Option name=“mute-affects-post-fader” value=“1”/>
Option name=“mute-affects-control-outs” value=“1”/>
Option name=“mute-affects-main-outs” value=“1”/>
Option name=“plugins-stop-with-transport” value=“0”/>
Option name=“stop-recording-on-xrun” value=“0”/>
Option name=“stop-at-session-end” value=“1”/>
Option name=“quieten-at-speed” value=“1”/>
Option name=“show-track-meters” value=“1”/>
Option name=“jack-time-master” value=“1”/>
Option name=“smpte-format” value=“6”/>
Option name=“timecode-source-is-synced” value=“1”/>
Option name=“no-new-session-dialog” value=“0”/>
Option name=“use-vst” value=“1”/>
Option name=“periodic-safety-backups” value=“1”/>
Option name=“periodic-safety-backup-interval” value=“120”/>
Option name=“default-narrow_ms” value=“0”/>
/Config>
extra>
Keyboard edit-button=“3” edit-modifier=“4” delete-button=“3” delete-modifier=“1” snap-modifier=
“32”/>
TransportControllables roll=“0” stop=“1” goto_start=“2” goto_end=“3” auto_loop=“4” play_selecti
on=“5” rec=“6” shuttle=“7”/>
AudioSetup>
periods val=“2”/>
priority val=“60”/>
ports val=“128”/>
inchannels val=“0”/>
outchannels val=“0”/>
inlatency val=“0”/>
outlatency val=“0”/>
realtime val=“1”/>
nomemorylock val=“0”/>
unlockmemory val=“0”/>
softmode val=“0”/>
force16bit val=“0”/>
hwmonitor val=“0”/>
hwmeter val=“0”/>
verbose val=“0”/>
samplerate val=“44100Hz”/>
periodsize val=“1024”/>
serverpath val="/usr/bin/jackd"/>
driver val=“ALSA”/>
interface val=“US-X2Y Audio #0”/>
timeout val=“Ignore”/>
dither val=“None”/>
audiomode val=“Playback/Recording on 1 Device”/>
inputdevice val=“Intel 82801BA-ICH2”/>
outputdevice val=“Intel 82801BA-ICH2”/>
/AudioSetup>
/extra>
ControlProtocols>
Protocol name=“Mackie” active=“no”/>
Protocol name=“Generic MIDI” active=“no”/>
/ControlProtocols>
/Ardour>