Connecting an effects board to Audio track

Hi,
I am a beginner at both music in general and Ardour in particular. I am using Ardour version 7.1 installed from the Manjaro Linux repo. I am using pipewire for the audio connections.
I have an old guitar effects board (Boss GT-10) that I am trying to connect to Ardour and record audio from. The board is connected using USB to the computer and is identified by the system properly. However, when I connect the board to the audio track input, there is no audio coming through. I was able to connect the board to Audacity and record there. I was also able to make a direct connection to my headphones. I also tried recording using Traktion Waveform 12, but failed there as well in a similar fashion to Ardour, so it may not be an Ardour only issue, but something that is more systematic.
I have been unable to solve this by myself, so a tip from the pros as to how to debug it further will be greatly appreciated.
Thank you.

Update: I did manage to record using the same environment on the current ZRythm beta. What can be wrong?

There are several inter-related things to check.

Does that mean Ardour is using the JACK backend?

Is the Boss device the only audio device? I do not know how Pipewire currently handles resampling a second interface for use with a primary interface. Jackd either v1 or v2 has an internal zalsa client for that, or can use the external zita_alsain/zita_alsaout programs to bridge audio from a second interface into the primary clock domain.

If the Boss device is the only audio device, did you select for Ardour to handle monitoring or for hardware monitoring of inputs when you setup the audio backend? If you selected hardware monitoring then you will need to use whatever control exists on the audio device to blend the incoming audio and the playback audio from Ardour together for listening.
If the Boss device does not have that feature, you will need to enable the software monitoring in the backend setup.

If using software monitoring of input then you have to be aware of the input state of the track. If a track is armed for recording the input should be the connected input signal, but if not armed for recording the input will typically be data from disk.

Those are the things I can think of, you can try those and report back if changing one of those settings fixed your problem or not.

First of all, thank you for the quick response.
Ardour indeed is using the JACK backend. The Boss device is not the only audio device, as there is also the audio interface on the computer itself (which is working). I hardly know pipewire - I only installed it a short while ago since I had other connectivity issues that I could not solve using JACK straight up - so I am not familiar with its inner workings. I did not do any special configuration on Ardour, so the monitoring is at its default setting (Ardour). I tried changing the setting to hardware, but the results are the same - no signal is picked up. Even the mere presence of Ardour somehow disables the output from the board - I can’t get any signal on any interface. Even after I close Ardour, there is no signal until I power off and on the Boss unit (there is no reset button that I know of).
Bottom line - I am still stuck…
Thanks again for your efforts to help.

This earlier post indicates that pipewire does support multiple audio devices:
multiple device pipewire post

The advantage of using JACK style function with pipewire is that you can test audio signals independent of what Ardour is doing. I would suggest connecting the output port of the Boss guitar processor to the input port of the system audio output and see if you can hear your guitar through your speakers or headphones or whatever you are using for monitoring. That will eliminate any issue with Ardour monitor settings, track armed or not armed, etc. Once you verify that you can actually get audio out of the Boss device, then you can figure out what you need to do in Ardour to make use of that.

It would help to clarify exactly what you mean by this description:

Does that mean you did what I was suggesting, connected the audio from the Boss to the motherboard audio interface, and were able to hear it through the headphones connected to the system audio interface?

Thank you Chris for the response.
Yes, this is exactly what I did - connect the Boss output to the input port of the system audio output (in my case, it was my headphones). The Boss did output a signal which I was able to hear on my headphones. However, as soon as I fired up Ardour, it automatically connected the Boss outputs to the “physical_audio_input_monitor_enable” (this is how it shows up in Carla) input of the Ardour app, in parallel to the previous connection to the headphones, and ever since, I can’t hear the Boss unit through the headphones, or Ardour. Shutting down Ardour does not fix this, and I have to power cycle (off-on) the Boss unit in order to regain the signal on my headphones (or any other application that does pick up the signal, such as Audacity). Something obviously happens when Ardour starts up that renders the Boss unit mute through the USB interface (I can still connect the phones output of the Boss unit to the microphone input of PC and pick up the signal from there).
Thanks again for helping.

This is going to sound weird…
I was finally able to get a signal in Ardour. I was going to connect the Boss unit to a Windows PC, to see how it fares there, but before doing so, I wanted to install the Windows drivers for it. Looking at the instructions there, I saw a remark that mentioned to verify that the unit connects to a USB 2 port, or a USB 3 port that supports USB 2. I was under the impression that all USB3 interfaces are backward compatible, but maybe I was wrong… Before transferring the (rather heavy) unit to the Windows PC, I plugged it into a USB 2 port on my Linux machine. It works. I still can’t explain why Audacity could work with it using the USB 3 port while Ardour couldn’t, but now everything works as it should.
If anyone can provide some explanation, I would be happy to educate myself.
At any rate, thank you for your time trying to help me out. I appreciate it.

They should be, but there are a lot of stories of audio interfaces not working properly when connected to a USB3 port. I have personally never seen a good explanation of what the newer USB controllers are doing incorrectly which causes problems for audio interfaces.