Compiling Ardour 2.8.13 - libraptor2

Tried to compile this version from SVN and got:

joe@Audio-Workstation:~/Desktop/Ardour2$ scons --jobs 3 scons: Reading SConscript files ... SCons.Script:18: DeprecationWarning: the sets module is deprecated Checking for pkg-config version >= 0.8.0... yes Checking for gthread-2.0... yes Checking for jack... yes Checking for sndfile... yes Checking for libgnomecanvas-2.0... yes Checking for glib-2.0... yes Checking for samplerate... yes Checking for liblo... yes Checking for libxml-2.0... yes Checking for lrdf... yes Checking for aubio... yes Checking for gtk+-2.0... yes Checking for raptor2... no raptor2 >= 2.0.0 not found. You do not have the necessary dependencies required to build ardour Please consult for more information

So I downloaded and compiled raptor2 and all compiling went smooth, but when trying to run Ardour I got a segmentation fault with:

raptor_new_uri_for_rdf_concept called with Raptor V1 world object

I guess it’s something to do with a mismatch between Debian’s librdf and raptor I compiled, tried to compile redland (librdf) but got install errors, any tips from someone on Debian squeeze?

EDIT: I also tried with SYSLIBS=1 with same error.


Thanks Pedro!

I’ll might give it a shot

Hi, joegiampaoli,

i had the same problem.

I’m running Slackware-13.37 (32bit). The solution for me was to find the library used by Ardour, which is linked against raptor1.

Something like this:

for i in find /usr/lib /usr/local/lib -type f -maxdepth 1
ldd $i | grep >/dev/null && echo $i

This will print all libraries linked against raptor1

Now you have to decide, which library is used by Ardour. For me, it was liblrdf, because i compiled version from SF. It’s wrong. Liblrdf must be newer version taken from github - . This version can be linked against raptor2.

LRDF from github is prepared for autoconf 1.11 - there are symlinks. If you have (as me) different version of autoconf, look at the symlinks, delete them in the building directory and copy the files from your /usr/share/autoconf… to the building directory (config.sub, install-sh etc).

After compiling LRDF from github, 2.8.13 works.

Happy recording!


if you use lucid, try to install the libraptor debs from precise repos, they worked for me and ardour doesn’t segfault. now if I could just figure out why my LV2 plugins disappeared…

That’s ok, I just wanted to update Ardour2, you know how we geeks love having the latest and newest of everything which can be a mistake sometimes…, I’ve been using Mixbus since it came out for linux so it’s not a big issue and I’m also moving on “psychologically” to Ardour3 which is also great.

I’ll might give those scripts a go to test again just to try, I’ll might as well do it in a VM also, because my system is working perfectly well and I do have more than what I need (still), so why fix what’s not broken, right? I really have to put my inner geek away and focus more in my music.

So no big deal…

Thanks again Paul!

@ vervelover: No, I’m on pure Debian “squeeze” so I don’t think that would work for me, but still thanks for the tip.

yes, i am afraid that its getting more and more complex to build ardour2. it is critically important that all the libraries involved are mutually compatible, and there are still lots of danging issues on several distros with RDF/Raptor. I don;t have any particular advice - if you look in svn in the tools directory there is a script called build-ardour-stack that downloads and builds all the software required for Ardour (it assumes that its companion, build-gtk-stack has already been run). I don’t use this on my own machine, but this is what we use on the build VMs. It may be helpful to look at this see to get an idea of the versions required so that all the libs fit together. this stack is also the one used for ardour3, btw.