Comments broken ardour 6.6 Linux

For some reason on Linux the comments section in ardour doesn’t open anymore. Is it just me
Ubuntu 20.04

I find it does open when I keep clicking but after it opens many windows of the comments. Something is not right here.

It works fine here, on Ubuntu 18.04.
I’ve tried with a self-compiled 6.6 and the latest git version.

Does it work if you start a new project? Perhaps there’s something in your current one that’s causing problems.
Or you may have something running that’s hogging your CPU and that’s why the comments only show up after a delay.

Running 6.6 on Ubuntu Studio 20.04. I’ve had some flaky things happen, but not frequent or reproducible enough for me to post an error report. Pre-6.6 (I was 6.5), everything went swimmingly. Then, when 6.6 came out, I would have several times where it it would hang starting. I would suggest that it was linked to whatever method she uses to fetch the “hey, version 6.6 is available!” message, but can’t say for sure. Sometimes I run with networking turned off. Since moving to 6.6, I’ve had a few flaky moments, one wreck on startup (which I believe was Jack-related), and a couple of other one-offs which I didn’t see again and didn’t majorly disturb my work.

All that to say… just tried creating a comment, and had no issue :slight_smile:

I believe it happens regardless but I will double check. I have tested it on windows and it’s fine so maybe it’s a Linux related bug

I don’t use the comments, but I have been testing and they work fine on my debian 10 machine.

There has been no change since 6.5 that would explain the difference, either.

Perhaps you have disabled showing the button in the Preferences > Mixer?
image

If you’re using KDE, perhaps the window opens behind Ardour’s main window?
There are some Preference > Appearance > Quirks for KDE users which may be pertinent.

The issue is resolved. Here’s what happened.
I have a dual screen setup and when I was running ardour in full screen mode in both screens when I clicked the comments, for some reason it would not open until I click somewhere on the editor window then the comments pops up right on the mixer and when I disable full screen on both screen but still have the editor and mixer on separate screens the comments works as normal where I would click on iit and it would open instantly