Command line to install Ardour

Which is the command to type to install Adour?
The only one I found online is the installation from the repo in Ubuntu with the sudo command, but it’s not what I remember I did the first time I’ve installed it.
It’s like a language: if you never speak a language you’ve learned, you forget it.
I’ve downloaded the latest version.
Thank you

First of all, navigate to the folder where you have the .run file you downloaded. Right click → properties → permissions → check the “allow file to run as a program” checkbox.
Now right click anywhere in the folder where you have the .run file and select “open in terminal”.
In the terminal type ./ in this case I guess ./
My explanation is based on the Mate desktop environment, I guess in other desktops it will be similar.

Thank you, Les Paul Junior. I’m on Ubuntu. I’ll try later and see if it works also for me.

What Robin (x42) usually recommends is to open a terminal, navigate to where you stored the download (which would usually be cd ~/Downloads), then run:

/bin/sh ./

That avoids some issues with having to make the run file executable, and dealing with some other quirks on some systems. Should work reliably on any desktop linux distribution.


I installed the program as per LPJ instructions and it worked.
Do you think is better to do like Chris says? If so, I’ll remove it and reinstall again.
However it seems to work, even if I haven’t tried it yet.
While doing the installation, I had this message about a frequency scaling which I have no idea what it is.
Any hint?

Then, after the installation was finished I checked the section about the plugins.
I don’t remember where I had the VST folder in the previous version, however can I create the folder and put the VST inside? I have some VST, not VST2, and sf2.

Sorry, I forgot. I have a low latency kernel.

No, if it installed for you then it is fine, the command line I copied from Robin just saves having to explain how to make a script executable. You obviously got past that step since you got it to execute.

That refers to the way processors will slow the clocks to reduce power when there is not a large amount of work to do, and speed the clocks back up when there is a lot of CPU load. The problem with that is the program execution is paused slightly when the clock speed is changed, which can cause glitches in audio or other realtime programs.
There are ways to set the CPU to run at a consistent speed using command line tools, but I don’t know what the easiest way would be on Ubuntu. If there is some kind of setting program that has a performance section, look for settings like on demand vs. performance, or power saving vs. performance, something like that. If it offers the choice to enable turbo mode or not turn turbo off as well.
Sometimes those settings don’t matter much, you can try without messing with it to see, but if you get a lot of underruns and overruns (marked in the Ardour markers as “xrun”) you will probably need to change that setting.

One thing you didn’t mention but is actually more important is that your current user account does not allow realtime scheduling. You need to make your user account part of the “audio” group to correct that. Look in the system administration utilities for the tool to let you modify group membership and add audio to the groups for your account. You will need to log out and log in again for that change to take effect.

The Ardour manual has a full section on dealing with plugins:
manual plugin and hardware insert chapter

Short version: yes, you can make a directory and put the VST files there, but you may have to update the Linux VST2 Path shown above to add the directory where you placed your plugins.

Thanks alot for the infos, Chris.
I’ve read that realtime audio can give problems in the system.
Ok for the VST folders, I imagined that the path must be changed accordingly to the place where I created new folders.
About the audio group. I’ve read in the page below that Jack optionally installs a file giving users realtime privileges.
I’m the only user on my computer, do I have to add my username to the audio group no matter what?

In the meantime I’ve added the invada plugins that are in the Ubuntu repository and the Maestro gran piano.
Now I have the virtual playing orchestra which has several folders like brass, percussions, strings, etc, containing the .sfz plugins. Since any folder has its own files, can I put them together in one single folders named sfz or is better to put all the different folders in a sfz one?

You learn something new every day. :blush:
Thanks for sharing the command, I will use it when I have to install Ardour 7 :wink: :sunglasses:

I am not sure what you refer to. Making audio programs run with no dropouts or audio glitches at very low latency can be difficult (for example running at 32 or 64 samples per period). Usually a period size of 256 samples or more is recommended. The default values which Ardour uses when selecting the ALSA backend should work reliably.

That is probably still correct. I use the Fedora distribution, I just checked there and it uses a group called jackuser instead of audio for controlling realtime privileges. A file is placed in the directory /etc/security/limits.d that sets which group is allowed to use realtime scheduling and lock memory to prevent swapping out the audio program under memory pressure.
You do not need jackd to use Ardour, but that may be the easiest way to get realtime scheduling permission setup (unless you want to spend time reading how that works and creating the necessary files yourself).

Yes, you still have to make sure your single user account is allowed to request realtime scheduling.

Thank you for the answer, Chris.
And yes, I use jackd because of Hydrogen drum machine.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.