clicks in audio

There appear clicks in any audiofile I play with Ardour. The clicks appear on different positions each time I play the file.
The sample rate is 44.1 in all: the file, ardour, Jack and audio interface.
The clock source of the audio interface is “internal”.
I run ardour 2.8.16 on Mac OS X 10.9

Can anybody help?
Thanks a lot.

what audio interface are you using?

I have this issue with an old mbox 1 that ive never been able to solve. Other interfaces can also be effected.

clicking can be caused by various things, incorrect buffer settings, usb ports sharing irq’s with other devices (like video card) etc

Do you get clicks if you play through your interface from another program?

I use motu mkII828. There is no problem with any other audio program (such as Logic, Max MSP). So I think it must have something to do with ardour or the Jack server. It sounds like something I had when I accidently generated a word clock conflict, but I think I checked all clock settings.

hi, maybe , a thing to check is the buffer size and to try with lower values…

try A3;
create a new session, you access to the buffer size in jack or in A3: Audio MIDI set up:
512 samples, 256, 128, 64…

jackOSX : JackOSX.0.90b24


I tried different buffer sizes already. Makes no difference.

Hm. I restarted the computer (as I already did before) and created a new ardour file. Now it works. Not a very satisfying explanation, I know, but for now the problem seems to be solved.
Thank you very much for your help!

feldforscherin: I’ll be interested to hear whether you continue to be click-free. I have one machine (intended to be my main recording rig, unfortunately) which produces small random clicks, both during recording and playback, without a single (correlated) xrun reported by jack. During some recording sessions the clicks are rare and almost imperceptible, but most of the time it seems like a kind of random “noise field”. I’ve discovered that it gets worse with increases in network traffic, which is interesting since this machine has a PCI network card, and the sound interface is a Delta 66 (also PCI). Swapping the cards had no effect. This is with A3 and pretty conservative jack settings, either from qjackctl or letting Ardour start jack itself. Otherwise I believe this machine’s HW and SW should be up to the task: AMD Athlon II X4 640 CPU @ 3 GHz, 8 GiB RAM, CCRMA low-latency kernel, LXDE, generally lightly loaded…

So here’s hoping that your problems don’t come back, but yeah it sure would be nice to have a root cause, wouldn’t it?