Clarett 8Pre USB?

I just updated my Lenovo Y570 to AV Linux 2020 (very new, not yet totally as stable as before) and I have Ardour 5.12 and even Ardour 6 testing.
I read some 2018 post somewhere in which there was some news about Clarett 8Pre USB. I tried it now. It seems the same problems are there. I can use it at the factory default of 48,000Hz. When I set up a new project, it won’t go with Alsa, I have to change it to Jack on the pop up window. Then it works.
Next problem, the input knobs for the gain on the Clarett do almost nothing until 9,6 position, and 10 is in the red, so one can hardly adjust that.
The headphones first came out on 7 and 8, but now they have changed to 1 and 2, I don’t know why. Atleast the output knobs for headphones and monitor seem to work normally.
I did stick the Clarett in a Windows laptop, change its input to 96,000Hz with the Focusrite Control, stuck it back in my laptop, changed Jack to 96,000Hz, but after about 20 seconds Jack would freeze. Also, the Jack seconds were slower than seconds, like around 40 per minute.
I need 8 mic inputs. Any suggestion to what Interface I might get? I had the Presonus 1818 from 2012 which was fantastic, but just died on me three months ago.

What’s AV Linux 2020? The last release was 2019.4.10
I’m responsible for the UK mirror of AV Linux and I haven’t heard anything about this, so I assume this is an early unreleased development version, but I’d be interested to know more.

As for 8 inputs, I don’t know about the Clarett, but one approach to consider is a USB - ADAT interface like the MiniDSP USBsteamer B (https://www.minidsp.com/products/usb-audio-interface/usbstreamer-box) and any 8 channel mic pre with an ADAT connection. The miniDSP unit is USB2 class compliant so will work with anything.

http://download.linuxaudio.org/avlinux/
On the page one can see that the latest version is 2020, so I thought I would try it. With Debian 10.
And then because I read this list also:

I was hoping I might be able to get the Clarett running. I will absolutely look into your suggestion, I hope I can organise this quickly, I can’t play concerts, so I would at least like to record. I suppose I might consider the Clarett 8Pre (without USB) and then with ADAT interface. Thanks for the quick answer, I have to send this nice rig back very soon or keep it. Ciao
Adam

To clarify about AV Linux,

A very early 2020 RC-1 test disk was put up on Linuxmusicians to collect data about Debian Buster, the new AVL kernel and boot and test UEFI installs only, it is in NO way intended to be permanently installed and used for actual production and a lot of new features have been included since the release of that RC.

Thanks - I found the LinuxAudio mirror after posting. And a mention on the Bandshed site that a new release is coming soon. If this is RC1 it looks promising (downloading now to try it out).

I have the MiniDSP and use it with the Behringer ADA8200. Not my main rig (that would not be Behringer), but I’ve used it with a laptop for recording away from home.

Edit: X-posted with Gmaq - thanks for clarification.

As far as the AVLinux 2020, definitely some things are not finished.
Setting up the German keyboard and the locales after installation don’t
work from the quick menu, and there was no Lilypond in the repositories.
I had to give it up - and go with the AVL19. I ordered the MiniDSP, so
I will write again late next week after I have tried stuff out. Thanks,
till then

blocked.gif

If you want to go Focusrite, the first and second generation Scarlett 18i20’s are close to 100% functional with Linux. The first generation seems 100% functional (I use this soundcard), the second generation I have no experience with but have heard it is close to 100%.

checking in. I got the Minidsp USB Streamer box.

I have many old DAT tapes and a good Sony DAT machine. I go out from the DAT with the TOSLINK to the USB Streamer in, and from there to the computer with the USB cable. I can see the 8 inputs and outputs in Pavucontrol and Jack. I set up Jack and Ardour with 48,000k, and in Jack I got USB Streamer set as Output and Input. Ardour wants to use Jack instead of ALSA. I don’t get any input level in Ardour. Am I missing something simple?

Discount the following, because porbably my Presonus is totally shot, instead of just having the USB connection not working. However, the phantom power lights do come on and the usb sync light is red. I got the Minidsp USB Streamer going from the ADAT connection of the Presonus to the computer. It shows up in Pavucontrol and in Jack with 8 system capture inputs. I set up Jack and Ardour at 48k. Ardour wants to run with Jack and not Alsa at the setup window. OK. I can’t see any input though.

Several things. Finishing up: the Minidsp USB Streamer is good. I had to flash the Streamer to stereo instead of ADAT and could then go from DAT to computer digitally.
I managed to find a “new, unused” Scarlett 18i20 first generation from Steptorise in Vilnius on Ebay. Multiple inputs are no problem, but outputs don’t even show up. I messed around with it for a full day and got speakers going, but the volume monitor and both headphones are together. (Pavucontrol still doesn’t show the Scarlett as possible Audio Output.) I can’t turn down the speakers and listen through the headphones separately. That doesn’t seem correct, but I can live with that.
I lost tons of time due to this. On my computer, the Scarlett 1st Gen only works through the USB 2 port, the two USB 3 ports don’t work with it. Here is my question -
Do these interfaces work over a USB 3 port? I hope this is just my Lenovo Idea Pad Y570 computer from 2012 and not new computers.

Hi, I own a Scarlett 18i20 1st gen, and the problem you are reporting about the volume of the headphones being paired with the volume of the speakers can be solved. But you need to use Scarlett MixControl at least once.

Screenshot 2020-04-29 at 13.38.36

Check the manual for more details. But, basically, in my case, buttons 1, 2, 3, 4 are turned on in blue, which means that their volume levels are tied to the physical volume knob position. They are also affected by physical dim and mute switches position. Meanwhile, 5-6, 7-8 (headphone 1), and 9-10 (headphone 2) are at signal level (I don’t remember the exact value). In your case, you might have that button also enabled for outputs 7-8 and/or 9-10 turned on.

There is no ALSA controls for these button from MixControl. But you can tweak the buttons shown in above image in MixControl and then, go to “File” > “Save to Hardware” to make them permanent. So, when you are back in Linux, since ALSA driver does not know about these controls, they will not be modified. However, keep in mind that it will also save in memory the complete status of the internal mixer and routing options, and that will be the status of the device when running on standalone mode.

Thanks for the help. I was able to find the mistake that I had been making. The only slight problem now is that there is a bit of soft crackle - like a slightly old record - while listening through the 18i20 on both headphones and speaker. When I listen later just through my laptop with headphones there is no more crackle. Anything I can do about that?
Ciao

That could be a bad configuration, maybe the buffer size is too little? Usually that produces xrun. Usually GUI programs for running jack (like qjackctl or cadence/catia) count them while jack is running. Also check that you ran jack with 3 periods per buffer, since USB devices usually are more stable with that value instead of 2, which is the default.

Hmm. I did have 2 Xruns in 20 minutes of recording. I have Jack set to
1024 Frames per period and it is at 3 periods per buffer. Should I try
more frames?

Ciao

Adam

blocked.gif

It should be enough. 1024 frames is considered quite safe for recording, and, of course, you will need external monitoring, because the latency will be too high. With a proper system configured you might be able to run it at 128, even 64 without any xrun.

In you case, I would there are other issues. There is a nice tool that do some checks on your system that can help find any problem:

Also, there are several guides in the internet about what to have in mind for setting up a machine to record:
https://manual.ardour.org/setting-up-your-system/the-right-computer-system-for-digital-audio/
https://wiki.linuxaudio.org/wiki/system_configuration

The last one has a lot of fine tuning configurations that you might not need, but check section " limits.conf/audio.conf" is a must. Installing jack automatically sets that file, but it is worth to check. Also if you are using a low latency kernel (or real-time kernel). Can you run jack in real-time mode?

Thanks so much for the reading suggestions. I am using AVLinux, so I am
guessing Jack is running in real-time mode. I already checked many
things, including “limits.conf/audio.conf”, on the list and they are as
suggested. I will keep going through the rest and see if I can fine tune
some more.

Till next time,

Adam

blocked.gif