Changing the default session name

When I create a new session, the session name defaults to a generated value using a template like “Untitled-YYYY-MM-DD-HH-MM-SS”. Is there any way to change the pattern used to something different? For example, I’d like to exclude the specific time a new session is created and simply use the date.

I’m sorry, no, the format is hard-coded.

So you have 2 options, file a feature-request in the issue tracker.ardour.org, or edit the source-code and compile Ardour yourself:

PS.

That could lead to duplicate names, in case you use the default name for more than one session on a given day.

2 Likes

Excellent, thanks for the quick response. It makes sense to me that this isn’t supported but I thought I’d ask. I appreciate the link to the code!

You can create a script to start with whatever name you like. For example, I have a script which starts Ardour with a name and specific (existing) template:

/opt/Ardour-6.9.0/bin/ardour6 -N ~/ArdourSessions/$(date +%Y%m%d.%H%M) -T QuickGuitarWithGuitarix

And then you can create a launcher or whatever for that script.

Although it may still be a bug with the naming, as the display of the session name in the window does/did not like the “.” in my date string (the actual session name would be saved appropriately). Yes, I did open a ticket :slight_smile: Not sure what ever happened with it. For example, session 20230117.0930 would only display as 20230117 in the session window.

$ /opt/Ardour-7.2.0/bin/ardour7 --help
Usage: Ardour [ OPTIONS ] [ SESSION-NAME ]

Ardour is a multichannel hard disk recorder (HDR) and digital audio workstation (DAW).

Options:
-a, --no-announcements Do not contact website for announcements
-A, --actions Print all possible menu action names
-b, --bindings Display all current key bindings
-B, --bypass-plugins Bypass all plugins in an existing session
-c, --name Use a specific backend client name, default is ardour
-d, --disable-plugins Disable all plugins (safe mode)
-h, --help Print this message
-k, --keybindings Path to the key bindings file to load
-m, --menus file Use “file” to define menus
-n, --no-splash Do not show splash screen
-N, --new Create a new session from the command line
-O, --no-hw-optimizations Disable h/w specific optimizations
-P, --no-connect-ports Do not connect any ports at startup
-S, --sync Draw the GUI synchronously
-T, --template Use given template for new session
-v, --version Print version and exit

1 Like

I’m not sure either… but if you only specify a session-name (not an absolute path) it works just fine:

Ardour7 -N foo.bar.123

creates a session in the default-session-parent-dir (Preferences > General > Default folder for new sessions).

Interesting! And correct! If you put a path in there, it breaks, but if you don’t, it don’t!

/opt/Ardour-7.2.0/bin/ardour7 -N 20230117.1515

Works fine. But:

/opt/Ardour-7.2.0/bin/ardour7 -N ~/ArdourSessions/20240101.1200

put the session in the right place with the right name, but puts “20240101” in the top of the session window. And I didn’t even know that I had the default target directory set. Ok, still kinda odd, but I can alter my scripts and start using them again! Thanks!

image

Not (and never was) a show stopper, just more weird… and it worked in, oh, before 6.9 or so.

And I would think, regardless, that this should help @metropoliswhirlpool to some extent.

Yes, this is helpful. Thank you both!

1 Like