Changing LADSPA/LV2 plugin paths (Flatpak)

I’m on Fedora 38 and I have a bunch of LADSPA and LV2 plugins I installed from their Audio Production group. Ardour is installed as a Flatpak, and it recently started not finding any LV2 plugins, and I don’t think it ever did find any LADSPA plugins. They’re all in /usr/lib64/lv2 and /usr/lib64/ladspa, but Ardour doesn’t look in there. I figured I should set the path environment variables to be those, and I used Flatseal, but Ardour still tried to find them in /app/extenstions/Plugins. I also tried setting them in the terminal and launching Ardour from there, but still no luck.

Is there something I don’t understand about environment variables and Flatpaks, or is this an Ardour thing? What can I do to make Ardour look in the correct paths? If nothing can be done about that, do you think moving the plugins to the paths Ardour looks in would work?

Basically when using the flaktpak’ed version of Arodur you also need to use flatpak’ed versions of plugins.

In our opinion flatpak is the wrong approach for pro-audio applications. You do not want to isolate the DAW, but allow it to interact with other applications and plugins. Furthermore you do want to use system-wide shared libraries (unless all plugins are statically linked).

So short of getting the official binary from Download Ardour | Ardour Community best ask your distro provider how to solve this.

I have the official binary installed, and it recognizes all of my plugins, but there are a couple of things that the Flatpak version has that aren’t in the downloaded version, such as the ability to use audio directly from other apps. I don’t have a microphone, so if I want to use a vocoder live instead of recoring my voice first and then vocoding it, I have to use my phone as a camera for OBS and then route the audio into Ardour and sidechain it into the TAL vocoder plugin, or video call myself through Firefox and do it that way.

It’s a minor inconvenience, and I think I’ll just continue using the non-flatpak version. I agree about Flatpak being a worse way to use a DAW, and only reason I installed it as a Flatpak was because the rpm package is still on Ardour 6.9. Perhaps the Flatpak version just doesn’t listen to environment variables? I don’t know. I tried linking from where Ardour looks to where the plugins actually are, and it still didn’t find them. All the LV2 plugins are Stale in the plugin manager.

Edit: Is it possible to specify multiple paths and have it work as expected?

You would use JACK or pipewire (which emulates JACK) for this puprose.

Could it be that you have set VST2 or VST3 path to a place where there are LV2 plugins?

I just realized I’m probably not using the variables right. I tried specifying multiple paths by separating the paths with colons, but it seems Ardour just doesn’t care and I should actually just learn how to do that, if it’s even possible. I have plugins in different places: all of my VST3s are in ~/.vst3, some VST2s are in ~/.vst and some are in /usr/lib64/vst, some LV2s are in ~/.lv2 and some are in /usr/lib64/lv2, and all LADSPA plugins are in /usr/lib64/ladspa, but it seems to be looking for more plugins than are in /usr/lib64/ladspa. I don’t remember moving them or uninstalling them, but Ardour seems to have seen them before.

Carla also doesn’t see Ardour at all when I’m running the non-flatpak version, and when I have Ardour open and my headphones plugged in, Carla doesn’t see them.

Just found out my session was on ALSA instead of jack :expressionless:
vocoder problem solved, I guess

Here are the path variables I have set:

I think I just need to learn how these things work

Compiled Ardour myself, now I’m wondering why I didn’t do it sooner. It fixed literally all of my problems.

For future readers using Fedora, these are the dependencies I had to install:
boost-devel alsa-lib-devel glib2-devel glibmm2.4-devel libsndfile-devel libcurl-devel libarchive-devel liblo-devel taglib-devel vamp-plugin-sdk-devel rubberband-devel jack-audio-connection-kit-devel aubio-devel libusb1-devel libusbg-devel pulseaudio-libs-devel libxml2-devel cppunit-devel libwebsockets-devel pangomm-devel liblrdf-devel lv2-devel serd-devel sord-devel sratom-devel lilv-devel suil-devel gtkmm2.4-devel
Keep in mind that this was for Fedora 38, so things might’ve changed if you’re reading this several years later.
After I installed those, I just followed the install instructions (using sudo for the ./waf install), and then ran ardour7 from the command line, and everything just worked. Then I used Alex Kryuchkov’s Desktop Files Creator to make it appear with the rest of my apps on GNOME.

Flatpaks can’t see outside of your Home directory. Manually move your plugins to a folder in your home directory, and then point your Ardour plugin search path to that folder in your home directory.

Not all plugins will work this way (because some plugins will expect certain path locations that have been hard coded into the plugin), but many will—especially the plugins that are standalone “.so” plugins.

The key with Ardour (or any DAW) as a flatpak and using plugins that aren’t packaged as a flatpak is the location of where the plugin is stored.

I discovered this yesterday when I tried to move Cardinal Synth (installed as a Flatpak) from its Flatpak directory to my ~/.vst3 folder, and it said something about a path it was looking for not existing. Downloaded it from the website and then it worked fine. Well, the LV2 version did. The rack in the VST3 version didn’t show up. But LV2 works fine for me, so it’s not a big deal.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.