Changes with BCF2000 and Ardour3

Hello all,

After hearing good things about the BCF2000 and Ardour for years now, I’ve decided to pick one up. Thanks to Ardour manual, I was able to get it working properly with little trouble (Mackie emulation mode). However, I’ve only been able to get the unit working with Ardour 2.8.12.

Being the avid Ardour fan that I am, I’ve been playing with A3 since the first alpha. Alpha 5 brought GUI changes for Mackie emulation mode, but I still can’t get the BCF2000 to work. Has Mackie mode functionality not made it into A3, yet? Or am I doing something wrong?

On a similar topic, I noticed that A3 doesn’t show up in the ALSA tab of ‘Connections’ in qjackctl anymore. Could someone explain the changes that are happening in A3 that would change this behavior?

(If it’s useful, I’m connecting the BCF2000 via USB and not MIDI).

Thanks for any responses in advance.

At this point I wouldn’t expect all of the Mackie emulation to be working yet in A3 personally sorry. But I haven’t looked at it myself yet, though Paul and I have discussed it so it is on the TODO list.



The BCF2000 will pretty much work with A3 if you use the generic surfaces code. Roughly speaking:

  1. Run JACK with -X seq or use a2jmidid so that Ardour can see the BCF2000’s MIDI ports.
  2. Choose “Generic MIDI” in Edit -> Preferences -> User interaction (check Enabled and Feedback)
  3. Double-click the “Generic MIDI” entry an dchoose “Behringer BCF2000 Factory Preset 2” or “Behringer BCF2000 Mackie Control” depending on the mode that your BCF2000 is set to.
  4. Use Ardour’s MIDI connection manager to connect MIDI control in and out to the BCF2000.

That should get it going. I have a BCF2000 here and I’m working on it (slowly…)

The reason you don’t see Ardour in the QJackCtl ALSA tab is that it doesn’t use ALSA MIDI any more, just JACK MIDI.


HI Cth,

Just a question regarding the factory preset 2… Does this have a limit too how many tracks using this preset?

I’ve been using a custom setup for my BCF for years… but using manual learning each time… I’m considering moving to pre-made maps if they can give me the flexibility I require.



@seablade and cth103: First off, thanks guys for the prompt response.

@seablade: Given all the work needed to get A3 ready for a stable release, I fully understand certain things need to get prioritize first. I’m glad to hear that it’s on the TODO list.

@cth103: Thanks for the run-down on getting the BCF2000 working. I had tried using generic surface codes before, but I missed step #4. I will go back and give it another go and see how it works for me. I remember reading about the change over to JACK MIDI, but I couldn’t find that info again; thanks for clearing that up for me.

All in all, I’m definitely excited for A3! Aside from the BCF2000, everything in A3 works beautifully for me. It’s going to be a great release.

Prior to Ardour 3, this old manual entry was true: “The 4 buttons in the lower right corner are already mapped in Preset 2 to the MMC transport controls Home (or rewind to the beginning of the session), Fast Forward, Stop and Play…” This seems to no longer be the case. In fact, though I’ve been able to manually assign the sliders, I haven’t been able to manually map the buttons.

So, how to map the BCF2000 buttons to the MMC transport controls now?

@devinvenable: if the BCF2000 preset causes those buttons to send MMC, then you just need to enable MMC control in Ardour, which can be done via Edit > Preferences > MIDI > Obey MMC Commands, and make sure the BCF2000 is connected to Ardour’s MMC input port.

if the BCF2000 preset does not send MMC, then this won’t work. However, the included BCF binding map(s) do involve bindings to control the transport. I don’t know which BCF preset they are intended to be used with.

Hi, I’m also using BCF with A3, without success…

-in generic mode, ‘reset all’, manual assign (CTRL+center click), it seems that it doesn’t save bindings. Isn’t there a ‘manual’ mode?
-in bcf2000 preset 2 mode, no chance, I don’t have factory preset 2 anymore and it seems impossible to reset
-in bcf2000 mackie emulation (any), it works pretty well (just no pan): when selected A3 sends all fader position to bcf, but then there is no feedback (saw nothing in midi tracer window) and each time I move a fader, it returns to its position. Also, I’m missing some rev/fwd etc that was present in A2.X with the buttons on the right, and the permanent assign of master on bcf column 8, with the channels swithing with < and >.

If someone could help me, I have a lot of mix work these days…

But I forgot to say A3 seems a great release, despite of that!


Blindekinder, the #2 preset is available as a download from the Behringer site. Follow any of the docs for loading a preset into the BCF - I know I wrote some stuff on how to do it that’s in various places on the web. You don’t even have to load it specifically into preset 2 (mine’s on 3) in case you’ve got something else set up in P2.

I’ve been having issues with having the bindings “stick”, I’m hoping to try A3.2 this weekend.

Thank you JoeHartley,
I did so, and seems to be the best working method… just, I don’t have a master fader.

This looks like this is still an issue. As Blindekinder reported, with the BCF in Mackie emulation mode the faders are connected but the physical faders return to their position (this has been reported in bug 0006035).

The preset #2 mode or generic mode with manual assignment, I can’t get any functionality.