Change from Ubuntu Studio 20.04 to AV Linux fix some Ardour 6 Problems

with the upgrade to Ubuntu 20.04 Studio there were some problems with Ardor 6. Numerous plugins no longer showed an UI. Ardor 5.12 from the Ardor download page showed the same behavior. 5.12 only worked as an integrated version of UbuntuStudio fine without the mentioned Problems.
The integration of the KXStudio Respos could not help.
Now with AV Linux everything is going so well (was recommended in support Chat)
Ubuntu Studio works with the embedded Ardour version very good, but as I noticed with previous versions, UbuStudio doesn’t get along with new versions from Ardour Website without problems.
This is my experience on completely different computers since Ubuntu Studio 14.
My AV- Linux has running now 5.12 for older Projects and 6.0 for new Projects.

Can you give examples of plugins that don’t show a UI? Would you mind posting on with those examples and the Ubuntu version and Ardour version (from the website) you did here?


Are the plugins only showing the generic UI?
You need to have suil installed for the native UIs, so check to see if you’re missing that.

Hi i had this gui Problem with Ubuntu 20.04 Studio i remember of guitarix
tube Screamer or eq10q or eq6q. Unfortunately i have no screenshot.
I try to describe…Plugin can be loaded in the Fader area like other
Plugins as well but with click of the Plugin nothing did happen.
No reaction no failure message. Some other Pugin works well Calf for

At an earlier time i tried e Demo version from Ardour 6 in Ubuntu Studio 19
i couldn’t see such failure .
Some assume an gcc Problem, its not a Ardour Bug i think its Ubuntu Studio
20 because some other Problems not Ardour related came up after uprgrading
from 19 to 20.

Kind regards

This is due to Ardour and those plugins being compiled using different versions of gcc. If you use the binaries from,, and, the GUIs will display correctly. You can run into conflicts if you use a combination of official binaries and distro-compiled versions.

Hi, thanks a lot. I will try this on another Computer i still have got the
Ubuntu 20 Studio.
I will give a feedback how the thinks are
Kind regards

Just installed the recommended eq10q
.deb Package for Ubuntu. The tar.gz brings some missing items to make
procedure. Install with deb. package. No problems …ok. Start Ardour 6…
same as before no gui. I am not shure Ardour use
again the old eq plugs but still not open gui.
I give up to spend too much time. As an long time ubuStudio user …i ll
see never so much
strange behaviour as to the 20.04. This proplems are not occured with
UbuStudio 19.
Anyway AV Linux might be for original Ardour
versions and Ardour upgrades the better change.
For well skilled Linux User i am shure they can fix it on Ubuntu.
Kind Regards

Strange… I got the same problem on ubuntu studio 19.10 :slight_smile:

Was ok with their v5.12 ardour and i lost the gui of eq10q when installed the official v6.0 ardour binary.

I then re-installed eq10q as said below, it works fine now.

Maybe the upgrade broke something in your ubuntu setup too?

I dont like distro upgrade, i prefer doing a fresh install with the new distro to avoid bad surprise :wink:

For the fun and if i get the time to do so, i will backup all my things and try an update this time.

If soi will tell you back the outcome for me.

EQ10Q has a special installer created by the author to sidestep library problems like yours.

You can try to uninstall distro version of the plugin and use the official installer:

1 Like

Yup that is what i did so far, as said works perfect now


In fairness to Ubuntu Studio they can only bundle and provide software within Ubuntu’s repositories so they will never be able to provide a build of Ardour from that has all the nips, tucks, tweaks, patched libs, and demo plugins that the ‘official’ bundle does, same goes for EQ10’s binaries from the developers site… Ubuntu can only provide versions that are built against their current shipping GTK libs within Ubuntu, they can’t build to match the GTK libs in Ardour’s bundles…

AV Linux is an independent project and can cherry pick from a lot of different sources to make things play nice together… It’s not a better or worse thing, just pointing out what the fundamental differences are to help explain why things like this happen occasionally…

1 Like

Did you try recording in Ardour 6 on Ubuntu Studio? If so, did you use a USB interface?

Nice tip! I wasn’t able to get EQ10Q to work with the Arch package but the binary installer works great. Thanks!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.