CD mastering challenge 2: from cd to cd - recording level?


Simply the task was to take existing cd and import the .wav to ardour for massaging.
Managed to create cd by:
a) setting location markers and cd checkboxes
b) fixing pregap by deleting 2s
c) exporting session
d) fixing .toc file START errors with emacs :slight_smile:
e) burning playable cd-rom with cdrdao

The recording ‘sounds’ great when played with ardour via soundcard but the burned cd-rom sounds ‘distorted’ with all my players.

What to fiddle?
1.) dithering - used none and rectangular without effect I can hear. And is this needed when the session is 42/16 from the beginning to end?
2.) mixer window - does fiddling with the ‘slide’ fix this problem?
3.) edit window - gain automation - is this the way to go?

Or some other trick? I remember that once I have seen some ‘white-paper’ explaining how to re-record the tracks by routing via jack to gamix and then back. Is this the way?

Thanx in advance!


See Sampos links:

Now I have made numerous trials with creating cd and the ‘distortion’ persist still. What makes me curious is that when played via ardour or alsaplayer the session or the exported session sound fine. After they have been burned to cd the ‘distortion’ occurs.

It is wise to have cd-rw and play it immediately e.g. with consumer audio
after (ac97 card) instead of testing with real cd-roms.
Also related finding is that not all cd-roms ‘get burned’ from 50 pcs spindle :frowning:
cdrecord blank=minimal -dev=ATAPI:1,1,0 ## to blank the cdrw
cdrdao disk-info --device ATA:1,1,0

1st finding:
Check hdparm for cdrom, mine was 16bit and not dma
/sbin/hdparm -c 3 -d 1 /dev/hdd

2nd finding: ‘distortion’ exists with cdrdao burned cd’s
2a) session export with and without dithering modes for original (copy from cd)
2b) session export Jamin -3,5 dropped input level for the whole ‘disk’.

3rd finding: TAP limiter with -21 gives almost no sound :slight_smile:
But with -1 the distortion persist.
with -1 and ridiculous -21 both in limits and output.

4th finding:
Ardour and jack would be wise to closed when burning because of the xruns.

5th finding: smaller range exports burned with cdrecord doesn’t distort
cdrecord dev=ATAPI:1,1,0 -v -pad -dao q*.wav
But they are significantly more silent than the cdrdao recorded ones and I think they are even too silent. The wav’s were as follows:
q1 - minus 1 – both limit and output
q21 - minus 21
qr - rectangular
qs - shaped
qt -triangular

Because of the success in 5th I decided to range export all the songs from the original ‘hot’ track piece by piece and then cdrecord as in 5th. And

6th finding: large session exported with ranges and burned with cdrecord distorts

So I am now recording again via ardour-jamin-ardour and by dropping the input about -1,5 with Jamin’s input (all songs are about equal level) and then I try both cdrdao and cdrecord methods.

Any hints are mostly welcome!


Oh I forgot to mention that I haven’t fiddled with:

a) big endian and little endia setups in the export
Aren’t the cd’s actually motorola like?
b) envy24controls setups, but why should I?
c) change my cd-rom and cdrw brand - the distortion occurs in the files anyway

I have other burner with same results.


Uh … how does this exported wav sound play on your soundcard? Tried to open the exported wav on rezound in order to see clipping? The session is 44.1 from the beggining, isn’t it? … Have you checked if you have latest libresample?

A-oops … Is there resampling for the session/range in export if I have envy24control / qjacktl set to 44.1k / 16 and I export the file to 44.1k / 16
Is it some internal thing? If so should I consider dithering - what each dithering does?

B-oops … I have the ‘latest’ rezound but I don’t know how to see the clipping. Or is it so that when the clip checkbox is active but there are no clips then there are no clips. btw. why to use rezound - could this feature be in ardour?

C-oops … libresample, where to look?

The export wav-files both range and session exports sound ok with alsaplayer -ojack
but when I burn them to cd-rom or cdrw the file is somehow distorted.
I can also verify by extracting the wavs with
cdda2wav dev=ATAPI:1,1,0 -vall -B -Owav
and then listening the wavs with alsaplayer and the distortion is now in the file extracted from the newly burned cd.

Again numerous trials and I have narrowed so far the only way to have not distorted cd.

  1. record the original (cd-copy) track with jamin -1,5dB to new track and have TAP limiter on 0dB for the master output post plugins.
  2. range export all range-marked tracks simply by names T01.wav - T19.wav (in my case)
  3. if cdrw: cdrecord blank=minimal -dev=ATAPI:1,1,0
  4. cdrecord -v speed=2 dev=ATA:1,1,0 -audio -pad *.wav

Note that in exports are named with .wav (could this be somehow the default behaviour?). Note also T01-T19 not T1-T19 because *.wav order might change with the intended one :slight_smile:

I tried many ways with cdrecord and cdrdao and I got mostly distorted frisbees. The 4) was the only way to get it to work so far.

Now new problem is introduced the default pregap of 2s is now inserted between each track. As I write this I try to use the cdrecord’s defpregap=0 (TEAC drive option which might go in the future) which should place 2s pregap only for the first track. I let you know what happened for my trial to make ‘dao’ via ‘TAO’ :slight_smile:

The problem with 2s pregap between each track (song) is that break between tracks is now extended with 2s and with danger of having ‘echo tail’ of the previous track in the new track. Actually I like the idea to be able to control this pregap issue, but I personally think it should be in ardour rather than expecting user to do some strange magic for the exported master tracks on command-line.
(actually it was very handy to have old sony discman player which flashes -2 sec in beginning of each track as indication of pregap)

I have started to suspect the following:

  • cdrecord
  • cdrdao
  • kernel?
  • lightscribe gigabyte dvd-writer
  • also the imation spindle has apparently cd-r’s which doesn’t pass the power calib or similar step right in the beginning

Also I noted that when burning wav-tracks (range exported ones) the -swab option has no meaning, no diff between files burned with -swab and without it. Maybe because -audio toggles -swab. btw. -swab and -audio (apparently) changes the little endian to big endian which is preferrable for audio-cd’s ?!
btw. I found this in ardour 0.99.3 a little bit confusing - should I be able to fiddle with it.


PREGAP resistance is futile … iow. Apparently on tao-mode the trial to get rid of 2s pregap between tracks with defpregap=0 doesn’t work on my gigabyte drive (maybe some ancient teac could do it according to man-page).

cdrecord -v speed=2 defpregap=0 dev=ATA:1,1,0 -audio -pad *.wav

So again between tracks there is extra 2s which makes makes me moose.

So I am back to cdrdao thing with the session exports and distortions and like. This sounds not actually ardour problem but …

again any hints are welcome… :slight_smile:


I am happy to announce that I managed to cook cd for myself.

couple of advice:
a) keep .wav in the export name so there will be 2 files:
The burning software can act on the extension.

b) check the settings per export and check the levels with sndfile-info

with master outs
with post plugin
[root@piano FULL]# sndfile-info FULL*.wav | grep Max
Signal Max : 2081 (-23.94 dB)
Signal Max : 20133 (-4.23 dB)
Signal Max : 0 (-inf dB)

From the above choices the winner was -4.23 dB

c) specify speed for cdrecord or cdrdao - I used:
cdrdao write --speed 2 --device ATA:1,1,0 FULL3masterin0TAP0.wav.toc
cdrecord -v speed=2 dev=ATA:1,1,0 -audio -pad *.wav

d) maybe its wise to close ardour and other tools before burning

The best result which wasn’t distorted was cooked:
1.) ripped the live-recorded cd (can’t recall what I used for that, shame on me).
2.) edited it with ardours edit
3.) placed range markers for pleasant places
4.) recorded the edited track by routing the outputs to Jamin and dropping input with -1,5dB and Jamins outputs to new track recording in ardour.
5.) placed plugin TAP limiter with limits in 0dB to master outs.
6.) exported several ranges (much faster than session) and burned tests, listened
fiddled with tons cdrecord options
7.) and finally exported session with best ‘sound’ setup experienced 4.-6. steps.
check master output levels if monitoring with them :slight_smile: they affect on export
8.) fix errors in .toc and burn with cdrdao
9.) testing of the fresh cd on different players

But thank you for reading this far :slight_smile:


… mmm … still curious about the problem you had. The fact that the export wavs sounded ok with alsaplay confirms that distortion didn’t came from the ardour session nor the limiter use. Sometimes I’ve had problems with disks burned too fast, regular players do not read’em or at least do not read’em well. The option “-speed 2” in cdrdao doesn’t always work, you should try “–speed 1” when you have problems. As the default behaviour depends on the cd writer driver in use, you should try to use always something like
cdrdao write --speed 1 --buffer-under-run-protection 1 --write-speed-control 1 mydisc.toc

in order to be sure that it uses all needed options.
Which cdrdao driver were you using? which cdrdao version?? which kernel, distro,ecc?
To get rid of 2s gaps anyway you must use SAO or DAO mode, which means usually cdrdao :^)

Thanx for very good advice -
you came to same conclusion that it is in the burning phase where things get broken. Now when I read this ‘saga’ I pinpoint myself maybe one problem in the burning commands.

2s pregaps can’t be avoided with TAO. Gotta use DAO or SAO.

I have used in the earlier trials device ATAPI:1,1,0 instead of device ATA:1,1,0
It takes ages to read the man-pages and to learn the hardware inside-out the hard-way especially when you are tired. Happy to use linux because of the logic in ‘abstractions’ in windoze I would have been giving up already. But I will explain to myself someday their difference.

Planet ccrma stuff:
Fedora Core 4 with ccrma packages

Slight problem maybe now with the writing speed 1 ? Lets assume 100+ cd-rom queue?
Should I purchase more cd/dvd writers ?


Thanx rotoquezada!

I figured out that as root life is easier with these commandline tools :slight_smile:
Hmmh… I feel that I gotta mail you to ask if this gentoo makes my life easier :slight_smile:

I gotta try these drivers as well. The cd is now 78:53 long and plays well in most of the players, two anomalies so far:

  • one dvd player refuses to play it
  • one cd player starts playing the disc again after end
    So think this is due to:
  • cd-r media + burn quality issue
  • 78 min long disk is oversize

Thanx for clarifying this speed 1 and speed 2 - I was wondering why those aren’t actually *1 and *2 speeds.

And joke of the day: one of the numerous ‘distorted’ cd-roms had very funny feature with my sony discman portable player. The player started to spin the cd-r but after a while the cd started to spin to OPPOSITE direction :slight_smile:

As time of writing I am struggling with some minor amendments on the ‘final’ cd version and then I will jump to the ‘lightscribe’ world. I definetely would like to have neat lightscribed logos on top of the cd-surfaces, esp. now due linux support.


Point about having dao can be read also from here:


Hi vaapo,

I’m using kernel 2.6.17-beyond3 (kolivas + gentto patches, quite a nice kernel if you can try it) and cdrdao version 1.2.1. I guess you should try with the newer version but changing driver might worth a try. Try –driver generic-mmc and --driver generic-mmc-raw
Besides, a normal user won’t be able to schedule the burning task in realtime mode (unless you’ve done all the realtime module issue) so you end up burning disks in low priority which is no good at all for quality mastering … Have you tried cdrdao as root?

As for speed, when I burn disks for myself (have a decent yamaha cd player) I go at max speed, when I burn disks for other people instead, I use to burn them with –speed 2 or even with –speed 1. These don’t mean speeds 1x or 2x but “first and second speeds available”, in my case something like 4x and 8x.

Oh, I’m using the ATA syntax for the devices!

… if need any more help, or perhaps doubts at 4am feel free to reach me at heuristic.records [#AT#]

Can’t resist to tell - that I managed to do very cute cd-label with lightscribe. I used the lacie’s 4L-gui to burn gimp-edited jpg.
So pure linux approach:

  • recorded with ardour
  • edited with ardour
  • mastered with ardour-jamin
  • burned with cdrdao
  • labeled with lightscribe in linux

and of course:

  • asked help with firefox+linux from this forum :slight_smile: between the steps.

Thanx for every1 developing ardour !



Have a look here:

Seems to be very good source of cd-r information.

After creating several lightscribed cd-r’s I detected that old pioneer PD-M40 player refused to play those.With more recent players they work.

After reading about yamahas audiomaster q.r. options for cdrecord (max.68min cd with it) I have started to think about the quality of the burned cd-r’s - are they handicapped when compared to normal cd’s because of the ‘error correction done behind the curtains by the cd-player’. Some claim that they can hear the difference of having the 'audiomaster option on’burned cd-r’s.

So what to learn from this thread ? Don’t blame ardour for ‘distortion’ on your fresh cd-r’s :wink:


saol bilader büyüksün sikiş erotik video sikiş erotik video