Can'ts Run Ardour and Linuxsampler at the Same Time

I’m trying to use LinuxSampler with Ardour and here’s the situation I’m running into:

Ardour 2.8
UbuntuStudio: 10.4
linuxsampler: 1.0.0
Fantasia 0.9

  1. I start JSampler Fantasia from /home/david/LinuxSampler. I have Fantasia set up to start linuxsamper.
  2. I create MIDI and Audio devices in Fantasia
  3. I load the instrument.
  4. At this point I can use Fantasia’s virtual keyboard to play the instrument.

Now, I’d like to use linuxsampler in Ardour. So, with Fantasia still running (I’m assuming I need to keep it running so it shows up in JACK’s connection manager, I start Ardour from the launch menu and get the message that Ardour could not start JACK. linuxsampler still has the hardware device (hw:0). If I reverse the procedure and start Ardour first, then I cannot create an Audio Device in Fantasia because Ardour has the device.

How can I get Ardour and linuxsampler to co-exist?



Are you sure you have set the Audio Settings in Fantasia for JACK? Fantasia has a choice of JACK or ALSA. If it is are set to ALSA it will tie up the audio system making it unavailable to JACK.

I’ve never tried linuxsamper (it’s on my list of stuff to do…) but you need to run linuxsampler with audio output to jack rather than alsa.
That way, you can route linuxsamper’s output to a track. The website says it’s possible and in fact the screenshots shows the button…

Thanks for the replies.

In Fantasia, I’m not given the choice of either ALSA or JACK. Only ALSA appears in the drop-down. Any ideas why that is happening and how I might correct that?

Another piece of information - I ran LIST AVAILABLE_AUDIO_OUTPUT_DRIVERS and it returned only ALSA, not JACK. How do I get linuxsampler to recognize JACK? Could JACK have been installed incorrectly?

I made sure JACK was running but AVAILABLE_AUDIO_OUTPUT_DRIVERS still only returns ALSA.

It looks like your LinuxSampler either wasn’t compiled with Jack support at all or you need to install support for it.
Search your Install Manager (like Synaptics) for “linuxsampler” and see if there is something called “linuxsampler-jackd” or similar.

It is unlikely that JACK’s installed incorrectly if ardour will run. Try starting JACK explicitly before you start either Ardour or linuxsampler. If you don’t know how to do that, try starting ardour first, and letting it start JACK.

If JACK isn’t running, it won’t be available as an audio output driver.


Used ./configure --enable-jack to enable JACK but linuxsampler still does’t recognize it. Must still be missing something.

Did you make sure configure reported that it found jack?
You need the developement files for jack installed if you want to compile LS with support for it.
Check if you have something like jack-audio-dev installed.

try using kxstudio-team’s ppa (sudo add-apt-repository ppa:kxstudio-team/ppa). There’s a version of linuxsampler in there that I know has JACK support. If Fantasia doesn’t have the option, try JSampler (also in that ppa).

Recompiled and installed linuxsampler making sure all libraries were present, the config was correct, and there were no errors. Now everything works fine. Thanks everyone for the valuable help. Now I’m on to my next problem: my Oxygen 25 Midi keyboard doesn’t show up as a JACK Midi device.

@david-guitar: hopefully you are running a2jmidid -e to act as a bridge between the ALSA MIDI and JACK MIDI worlds.

Actually, I created the MIDI device using ALSA in JSampler and the Audio device as JACK. This allowed me to connect my Oxygen 25 to linuxsampler and now all is right with the world. I guess I didn’t need my Oxygen to act as a MIDI controller, just an input to linuxsampler. Thanks everyone for your help.