Can't start on Windows 8


(tarelka95) #1

Can’t start Ardour6 (6.0.pre0.1228-dbg-w64, previous builds the same did not work)
Starting initial configuration, at the last stage in the application fails.

Error that displays debugger, but does not save in the log

Assertion failed!

Program: C:\Program Files\Ardour6\bin\Ardour.exe
File: /home/ardour/win-stack-w64-dbg/include/boost/smart_ptr/shared_ptr.hpp, Line 734

Expression: px != 0

log debug (include “thread apply all bt”) (“link” - life 1 day or 20 downloads)

p.s. Sorry for my english


(Paul Davis) #2

We’re not particularly interested in reports about current GIT master, unless something has changed about its behaviour very recently.

We cannot recommend using 6.0-X for anything except occasional testing.

Unfortunately, the debug log doesn’t appear to show any obvious hint of what the problem is. We would probably return to this once we get closer to thinking about actually releasing 6.0.


(Andy) #3

The same behaviour on Debian 9 and Ubuntu here…also tried on a Win10…won´t start Ardour 6.0-X.

(ardour-6.0.pre0.1204:7305): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 5 char 5: Element ‘i’ was closed, but the currently open element is ‘markup’
Speicherzugriffsfehler
thanx


(Robin Gareus) #4

It is known and understood issue, related to starting Ardour6 the first time without prior TimeMaster config (new work-in-progress). For the time being, stay with Ardour 5.12.

To start Ardour6 in the future you may also have to delete the current preferences (once the issue is fixed). Those would be: on Windows %localappdata%\ardour6, GNU/Linux: $HOME/.config/ardour6, OSX/macOS $HOME/Library/Preferences/Ardour6.


(Andy) #5

Thanx a lot Robin…now it works…