can't start ardourvst

Please, tell me what I’m doing wrong?

Ubuntu 10.10, Jack 1.9.6 from kxstudio repo. Compiled manually ardour2 with VST.
With different wine versions gives me this fault:

Cannot mmap shm segment /jack-1000-0
Map shared memory segments exception -2
wine: Unhandled page fault on read access to 0x00000003 at address 0x7099f54c (thread 0026), starting debugger…
Unhandled exception: page fault on read access to 0x00000003 in 32-bit code (0x7099f54c).
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
EIP:7099f54c ESP:0032fb70 EBP:0032fb98 EFLAGS:00010202( R- – I - - - )
EAX:ffffffff EBX:709b5ff4 ECX:000003f4 EDX:709b5ff4
ESI:00000040 EDI:7ac10008
Stack dump:
0x0032fb70: 709ab288 00000000 00000000 29ab2200
0x0032fb80: 0000000f 414a0000 7099f44b 709b5ff4
0x0032fb90: 7ac10028 00000000 0032fc78 7099ea7c
0x0032fba0: 7b54c510 709a4793 68a30165 00000001
0x0032fbb0: 0032fccc 7e019c6c 7e019bb4 7e019afc
0x0032fbc0: 7e019a44 7e01998c 7e0198f4 7e01988c
=>0 0x7099f54c in (+0x2c54c) (0x0032fb98)
1 0x7099ea7c in (+0x2ba7b) (0x0032fc78)
2 0x7099eb85 jack_client_open+0x54() in (0x0032fca8)
3 0x6882a01d _ZN13EngineControl14engine_runningEv+0x2c() in (0x0032fca8)
4 0x6882a01d _ZN13EngineControl14engine_runningEv+0x2c() in (0x0032fca8)
5 0x68666618 _ZN9ARDOUR_UI7startupEv+0x47() in (0x7dda7db0)
6 0x686768cc _ZN4sigc8internal10slot_call0INS_18bound_mem_functor0Iv9ARDOUR_UIEEvE7call_itEPNS0_8slot_repE+0x1b() in (0x7dda7db0)
7 0x79d54ba2 _ZN9Gtkmm2ext2UI3runER8Receiver+0x101() in (0x0032fe34)
8 0x688bd0c0 ardour_main+0x53f() in (0x0032fe50)
9 0x68317947 main+0x26() in ardour_vst (0x0032fe90)
10 0x7b8560ac call_process_entry+0xb() in kernel32 (0x0032fea8)
11 0x7b8560ac call_process_entry+0xb() in kernel32 (0x0032fee8)
12 0x7b856d4f start_process+0x5e(peb=0x7ffdf000) [/build/buildd/wine1.3-1.3.8/dlls/kernel32/process.c:997] in kernel32 (0x0032fef8)
13 0x7bc71990 call_thread_func+0xb() in ntdll (0x0032ffc8)
14 0x7bc74530 call_thread_entry_point+0x6f(entry=0x7b856cf0, arg=0x7ffdf000) [/build/buildd/wine1.3-1.3.8/dlls/ntdll/signal_i386.c:2473] in ntdll (0x0032ffe8)
15 0x7bc49daa start_process+0x29(kernel_start=0x7b856cf0) [/build/buildd/wine1.3-1.3.8/dlls/ntdll/loader.c:2610] in ntdll (0x00000000)
0x7099f54c: movl 0x4(%eax),%edx

May be I should post a wine bug?


are your running a 32bit or 64bit Ubuntu (uname -m in a console should give you the result if you are not sure, x86 ist 32 bit, x86_64 ist 64bit)?
You cannot run Ardourvst in a 64bit environment, at least to my knowledge.

Apart from that, I would not recommend Ardourvst at all, it is mostly unstable, subject to change with every wine version, and it will be hard to impossible to get support for it.


HI rusk,

     With  similar configuration my machines are working fine.

  1)   Ubuntu 10.10  , jack 1.9.5 from repo , ardourVST 2.8.11 compiled from source 

  2)    Ubuntu 10.10 , jack 1.9.5 &  ardourVST 2.8.11 from repository 

             I think Jack from kxstudio repo is  meant for Ubuntu 10.04 and I don't know if it works in 10.10. Try compiling or use repo

BTW, 1.9.6 from kxstudio repo works fine with my 10.04 machine


edit ; WIne is 1.2 1 from repo -in all machines (actually there were no problems under any of the previous ver. of wine)

Benjamin Scherrer, I have 32 bit only CPU and all software is 32 bit. Ardourvst, compiled with ubuntustudio package works fine vith my favorite plugins. All troubles I have are because I want more usability. Some VSTi-s with big sample banks outside of DAW, but insert effects - in place… And all stuff sinchronised, saved and launched together… I will try to compile all these stuff with ubuntustudio.

manmachine, but fst and festige requires wine 1.3… latest fst don’t want to compile with wine 1.2.

rusk said: fst and festige requires wine 1.3… latest fst don’t want to compile with wine 1.2

      I dont think so.   Ubuntu 10.10+wine1.2.1+festige0.8.3 -   just works

I have now worked ardourvst. It runs with jack 1.9.5 and wine 1.3. But cannot start with jackdbus. So I can’t use session managers with ardourvst… May be there are another solutions for quick save/open komplex projects??

Yes, I know that all vst-s I can run with fst and insert via returns. But how can I save all params and reopen next time??

I understand the problem. Ardourvst crashes with jackdbus. If jackd started from qjackctl - ardourvst runs fine!

Thanks for Nedko!

Reducing default value port-max solved my problem!

Now it works perfect with port-max value 128. Default value was 2048.

strange things:
with default value ardour2 works perfect and ardour3-vst works too.