Can't start Ardour the 2. time

I know that there isn’t any support for Ardour on Windows, however I’m just asking, if any of the Windows users have been in a similar situation.

My situation is that I managed to get Ardour up and running after starting both Jack PortAudio and Jack Connection Kit. And all worked fine.

Then I successfully exported a .ardour session from Blender with:

And tried to open Ardour with a right click - open with Ardour - on that exported file, and from then on I haven’t been able to open anything other than the pre-release warning in Ardour. so I suspect that some ini setting is causing errors when starting Ardour.

I’ve tried to:

  • Delete the C:\Users\User\AppData\Local\Ardour5 folder
  • Clean the registry
  • Uninstall/reinstall Ardour
  • Reboot computer

All without any succes. Any suggestions on what I can try next?

Thank you for your time helping me out, unfortunately I can’t start Ardour at all yet again, so I can’t even get to those settings.

Have you ever had another monitor connected? I mostly use Mixbus but I’ve seen situations where Mixbus will start - but the opening window is off the screen somewhere (usually because Windows thinks there’s an extra monitor which isn’t connected any more). The usual symptom is that you won’t see Ardour when you try to launch it - but there will be an Ardour icon, down on your taskbar.

Is it possible to run Ardour on Windows without Jack?

Or are there any tutorials on how to run Jack correctly in combination with Ardour on Windows?

Can I manually chance the used sound device from Jack to something else in the settings file? If so, what and how?

Is it possible to run Ardour on Windows without Jack?

Or are there any tutorials on how to run Jack correctly in combination with Ardour on Windows?

Can I manually chance the used sound device from Jack to something else in the settings file? If so, what and how?

“Is it possible to run Ardour on Windows without Jack?”

Yes. I run Ardour on Windows without Jack installed. Jack is much more useful on GNU/Linux where it can interact with other Jack applications like Guitarix and Hydrogen. Few Windows applications use Jack, so there is not as much benefit installing it on that platform, in my opinion.

Strange - now I managed to open Ardour without having Jack Control and Jack AudioPort running - but now I can’t hear any audio from Ardour.

Can I ask you what are your Audio/Midi settings? What audio system do you use instead of Jack? And driver?

I’ll be home tomorrow night and will give specifics on my setup once in front of my computer, but if memory serves me, I think I select ASIO as the driver. I had ASIO4ALL installed on my computer prior to installing Ardour, and Ardour seems to have no problem detecting and using that driver.

On my laptop I have Windows 10 Home 64-bit with ASIO4ALL v2.13 and Ardour 4.7.0 [“Cluster and Eno” (built from revision 4.7) Intel 32-bit] installed. My reason for installing the 32-bit version of Ardour on a 64-bit OS was plugin compatibility. On Ardour’s Audio/MIDI Setup screen, I have the following options selected:

Audio System: PortAudio (default)
Driver: ASIO
Input Device: ASIO4ALL v2
Output Device: ASIO4ALL v2
Sample Rate: 48 kHz
Buffer Size: 512 samples

MIDI System: WinMME

Just prior to typing this, I confirmed that I get sound in and out of Ardour using a USB audio interface, and MIDI works using a USB MIDI keyboard with these settings. However, I first had to check my USB audio interface was the default device in Windows Sound settings and also mark the device ‘Active’ in ASIO4ALL’s settings manager. Windows defaulted to the USB device upon plugging it in, but ASIO4ALL required manual intervention. It activated my built-in sound card by default instead of the USB audio device. The buffer sizes were also mismatched between ASIO4ALL and Ardour, so I adjusted that. The ASIO4ALL icon doesn’t appear in the system tray until after starting PortAudio in Ardour’s setup screen, so after making the necessary changes, I had to stop and restart PortAudio for them to take effect. After that, everything worked as expected. Hope this helps.

My first suggestion would be to follow the suggestions for getting a backtrace that you can read here: (the Windows specific part)

This may give some clue about what is happening (or not happening). Please don't post the backtrace to the forum - file a bug report at and attach it to the report.

Is jack already running? I’ve seen cases where Ardour can hang for a few minutes: Ardour checks for jack, jack is not yet running, jack tries to auto-start and fails repeatedly until it times out after a minute or three.

The very first time you launch Ardour, Ardour always asks which soundcard/system to use. Next time you start Ardour it trues to use JACK automatically if you used JACK in the past. So that may explain what you’re seeing.

PS. the Ardour config is in %localappdata%\ardour4\ (not in the registry)

Thanks, I reported the bug here:

Maybe it’s just me not understanding how to run Jack correctly?

Btw. ardour-4.1.349-w64-Setup opened correctly, but then crashed for different reasons. I’m trying to export an edl from Shotcut, import it in Blender, and then export it from Blender as an .ardour session, which actually opened fine in ardour-4.1.349-w64 (but then crashed when I tried to delete a track).

Ardour 4.1 ? Why would you be trying to use that? Did you really mean Ardour 4.1 ?

Yes, I had it in my download folder, and I could only find the most recent nightly on the download page.

Current release is 4.7; nightly builds are 5.0-pre0.

4.1 is basically ancient at this point. There’s not much point putting any attention on the behaviour until you can show that 4.7 or 5.0-pre0 behaves the same way. I’d prefer it if you could test 4.7, but that’s not really possible, alas.

I have the Windows 4.7 executables saved (I keep an eye out and save the major release versions when they show up on the nightly site). I could pass them along via TeamViewer or some other means if it helps, but I am traveling at the moment and won’t be home until late Thursday. …might be cumbersome to coordinate that via the forum, and I’m not sure if I am stepping on any toes, though. Just putting it out there…

I had the ardour-4.7.1379 in my download folder (maybe I should be doing some housekeeping once in a while?) and it doesn’t start (no pre-release warning). Unfortunately it isn’t the debug version - so I can’t produce a log. The bug report was in connection with 5.0-pre0, as written in the report.

So I guess it’s a dead end from here. At least I managed to verify that it is possible to export an EDL from Shotcut, import it in Blender and export an .ardour session file, which could be opened in Ardour, by using 4.1. So in other words people should be able to do the sound work of their Shotcut video projects in Ardour. A good thing.