Can't start ardour 2.4.1

I have compiled ardour a billion times (ok, maybe half a billion…), with no problems, but for some reason, I get the following error (in an xwindow, not terminal):

Cannot find icon image for ardour_icon_16px.png
Press to Exit

Then once I click the button, it closes. Recently I had all kinds of permission issues with my home directory, and that is the only thing I can think of that might keep this from working…I tried

scons install unistall
scons install -c
scons -c

then recompiling, but that doesn’t seem to help…anyone have any ideas?


With a little help from IRC, I did a chmod 644 on all the files in /usr/local/share/ardour2/icons and it now starts…thanks edogawa!!!

Hi MuzicMan0

It’s funny I had the same thing happen to me. I downloaded Ardour 2.4.1 to my USB key and extracted it on the key, I then copied the extracted folder to my home drive to compile and had the same error you described.

Just for kicks I downloaded the source directly to my home drive and extracted and compiled it and it would start then without issue. Weird!

Unfortunately, now I have the dreaded wine error, so it’s either go without VST, or reinstall my OS…haven’t decided which I’m gonna do yet…


While I completely understand why the VST thing with Ardour is the way it is…- kind of like trying to get Chevrolet parts to fit on a Saab! It certainly is very limiting in what your choices are, I ran Ubuntu 8.04 for 2 days and it totally wreaked havoc with the good thing I had going with 7.10. With ArdourVST the whole enchilada revolves around Wine, I took several days and evaluated 10 versions of Wine (man was I drunk!LOL) Only 0.9.49 worked properly, which sucks because Ubuntu 8.04 will not allow you to go back that far! I tried 0.9.59 and 0.9.60 in Ubuntu 8.04 and it just wasn’t going to happen. If you get it figured out please post back. I liked a lot of things about 8.04 so it’d be nice to get a stable ArdourVST to run on it.