Can't save presets in Calf Fluid Synth

So I’ve got this Calf Fluid Synth as a plugin in my MIDI track. When I open it, all the channels have Acoustic Grand as default instrument. I meticulously set every channel to a different one but when I click “Save” all the channels go blank and nothing’s saved. When I save anyway, calling the preset up gives no instruments in the slots.
Am I doing something wrong?

Hmmm … wrong forum? Or is the question too stupid? If so, I thought you’d better cope with it because that’s what I’m good at :wink:


If so, recent version from and upcoming Ardour 4.1 resolve this issue.

If you do not get Ardour from or compile it yourself, make sure that you have recent liblilv from SVN installed on your system.

PS. Issue like this are best reported, discussed and kept track of in the bug-tracker.

Hey, thanks x42 - I don’t think I’d come up with the courage of calling something a bug if more often than not (in my case) the problem is sitting in front of the computer! But thanks for the link, interesting read.

Right, solved!

I lied above, I installed something called calf_0.0.60.orig.tar.gz, which i found on t’internet somewhere (ubuntu specific, I thought). So, I re-attempted an install of the proper file from Calf- ignoring the included INSTALL file instructions (./configure, make, make install), but followed the proper instructions on the Calf website (./, make -j8, make install
: had to install a few dependences : libglade2-dev to get the proper GUI and lv2core, amongst many other dependencies that Calf required).

All fine now, my presets stay preset.

Sorry about that, carry on.


Thanks x42 - it’s the Fluidsynth only, I think, all other Calf / LV2 plugins are ok.

Ubuntu 15.04 installs “calf-plugins 0.0.19+git20140915+5de5da28-1” - so I found that Calf had a newer version as a tgz : - I installed this, but the only plugin it didn’t contain was … Calf Fluid Synth! Dang.

Any way to get the latest Calf Fluid Synth? Or I’ll wait for Ubuntu to use a newer version in its standard install.

Ho hum,



I still get this issue with Ardour 4.1 and 4.2 (the pre-built versions : - I’ve updated liblilv with the latest versions - do I have to compile Ardour from source to have a fix for this? I’ve reinstalled he Calf packages too.

Very confused, sorry!


Anyone? :slight_smile:

Ok, to get to the bottom of this issue…

Do plugin presets work for other LV2 plugins? No -> ardour/liblilv bug, file in

If yes, do presets work for other LV2 plugins that use external files (e.g ir.lv2 or convo.lv2 or rkr.lv2)? No -> ardour/liblilv bug,

If yes, do Calf Fluidsynth presets work properly with the latest calf release? No -> bug in calf, please report at

I do not have the calf plugins installed and the answer to the first two question is yes here (tested with Ardour 4.2 from, on Debian GNU/Linux, Win 7 and OSX 10.10).

PS. To properly support plugin states liblilv 0.21.3 (svn, march 2015 or later, still unreleased) is required, Ardour binaries from come with this library, there is no need to install it separately (unless you compile ardour yourself).