can't run ardour 4 on ubuntu 14.04 (64-bit)


i am running ubuntu 14.04 64-bit, i installed it just a moment ago. I am unable to run ardour 4 by clicking on the icon. If i try this in terminal: ardour4 -N new i get these errors:

WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with ‘ulimit -l’, and it
is normally controlled by /etc/security/limits.conf

/usr/lib/x86_64-linux-gnu/ardour4/ardour-4.6.0+r14412: symbol lookup error: /usr/lib/x86_64-linux-gnu/ardour4/ardour-4.6.0+r14412: undefined symbol: fftwf_make_planner_thread_safe

Any one could help?

I have exactly the same issue with the same message.

Please get Ardour from or file bug reports with the vendor/distro/PPA.

fftwf_make_planner_thread_safe is present only in fftw version 3.3.5. You are running a version of Ardour which was linked against that version of the library, which you probably don’t have in your system.

@tartina And what would be the solution?

@amir see x42’s post.


I presume you downloaded the .deb from my PPA, rather than adding the PPA to your apt sources, and force installed it with dpkg. The PPA has some updated libraries as well, such as fftw3, which ardour there is built against. If you want to use the PPA, you need to add the PPA and then run apt-get update and apt-get upgrade.

I think that problem is not of ardour but of jack. Check this


No sorry. This is a problem with how whatever package is being used is compiled and distributed. As tartina commented, it needs a recent version of libfftw, which may not be distributed on many systems by default. It needs this due to some issues with plugins and being thread safe when multiple instances were instantiated using fftw, which was not thread safe. The package from Ardour distributes this with it to ensure compatibility, but packages built by others may not, as dobey mentioned above, he has a package on a PPA that installs via Ubuntu’s package manager, but you need to install the PPA, not just the .deb from the PPA which will not include an updated libfftw.

Jack has no dependency on fftw as far as I know, so this is in no way connected to Jack.



I’m curious as to why is there another Ubuntu Ardour PPA building Ardour against Ubuntu system libraries, this has failed time and time again in the past. The KXStudio repositories are already shipping a repack version of the official Ardour bundles which have all the internal library stuff nicely sorted out for libfftw and a host of other potential conflicting libs ‘accidents waiting to happen’ and the KX Repositories are already completely compliant with both Ubuntu and Debian (including gcc5 builds) and are providing a version that the Ardour developers endorse and support for Ardour users requiring assistance. The Ardour developers have said in the past that they don’t endorse distribution packages of Ardour and the unfortunate truth is the more Distributions that package it the less potential for users to directly support the project and the higher ‘signal to noise’ ratio on Ardour’s IRC as they troubleshoot Distribution issues that aren’t of their making.

If things have changed and Paul endorses this new PPA I will gladly sit/stand corrected but based on past experience with Ubuntu (and other Distro packages built against system libs) I think people would be better served on Ubuntu and Debian by using either Ardour bundles from here directly or the re-packaged bundles provided by falkTX in KXStudio repos.

@GMaq no idea if this is the case here, but I for a short time looked into having a launchpad PPA to handle building packages custom for my own personal use, and in those cases I wouldn’t have any problem keeping it public for others to use, but it wasn’t my goal to build for others necessarily. So there are reasons to possibly do it other than simply to distribute it, but yes everything else you said is pretty accurate I believe.


With the Ubuntu 14.04 repository version ardour 1:2.8.16+git20131003-1 is available to install. This version can be installed and works. The same Warning mentioned before pops up at starting but it works.
After de-installing I added ubuntut trusty main

to the list of software sources in Ubuntu Software Center.

Now version ardour 1:4.6.0+r14412.40~ubuntu14.04.1 will be installed.

This time I could start ardour.

Then I tried to start a project with the default settings under “New Project”. Selecting dummy Audio-Systems it works. Selecting ALSA or JACK and pressing the Start button returns “Audiogerät ungültig” meaning Audio not valid.

How to overcome this next hurdle?


We do not support any versions of Ardour except the ones we distribute via Issues with other packages of Ardour need to be taken up with the packager(s).

Your issues with the audio setting are likely too complex for anyone to want to solve them on a web forum. Join us on IRC where we can interact with you in realtime and get the problem solved.

@GMaq this isn’t the place to have that discussion really, but KXStudio does not have ardour in the PPAs, nor is it building daily builds from git. Also, there are some serious issues with KXStudio packaging, which I don’t want to get into a big argument about here. Those packages are not compliant with debian/Ubuntu policies.

OK. I installed ardour version from your website. Now it works. Thanks. I am going for the first recordings now.

Thank you for your support!


As far as Ardour’s availability it is packaged in the KX Repos, however as of this writing Ardour 4.6 is not available yet, on the rest we’ll agree to disagree I guess, however I will certainly agree that my post was off-topic in this thread and for that I apologize to the OP and others reading…