Can't record on ardour with alsa

I’ve gone through hours of attempting to configure this software with jack and simply don’t want to run qjackctl everytime I turn on ardour, a FOSS software that I was considering as a main DAW.
I’ve installed ardour using sudo apt install ardour

ALSA won’t record, JACK throws the error: —ERROR: JACK: Cannot create thread res = 1 ERROR: JACK: JackClient::AcquireSelfRealTime error ERROR: JACK: Cannot use real-time scheduling (RR/5) (1: Operation not permitted)
and it doesn’t even let me close the program due to some glitch overlooked somehow in the development process.

And by “ALSA won’t record” I mean that I followed the stops in Ardour 6 Quickstart (recording, editing, mixing and exporting) - YouTube verbatim and can’t even use the basic functions.

My question: How can I learn to fluently use ardour

Those errors means your system is not properly set up for realtime operation. See here: How do I configure my linux system to allow JACK to use realtime scheduling? | JACK Audio Connection Kit

Even if you don’t use Jack, this still applies for ALSA as well, so make sure you set up your system properly. That being said unless you know you need Jack, I would recommend focusing on getting the ALSA support working.

And of course tell us what actually happens in more detail when using ALSA, what happens vs what do you expect to happen when you do what command?

   Seablade

Hello, I just went through the steps in the the article listed above while translating the steps to use them in ALSA. Ardour is still not recording properly after a restart of my system.

Here’s what ardour is doing now:

I attempted to add images showing the progress in attempting to start, Audio/MIDI Setup and other images along the way, but was stopped by the rule to upload only one image on a post for new users. In the Audio/MIDI setup it says ‘Stopped’ between ALSA and start. I went to routing grid by pressing the button above ‘Comments’ and before that, when the DAW is initially started up, the feedback button wasn’t blinking orange (I’m simply trying to communicate details of the images the new user rule prevented me from uploading).

After add a ‘monophonic track’, pressing the record button in only the track, enabling the system and master in for left to left and right to right, all according to Ardour 6 Quickstart (recording, editing, mixing and exporting) - YouTube

I’m still not getting any audio feedback in my headphones from ardour while this is playing, while the system indicates both my headphones and microphone are connected and enabled. When I switch to system audio and try this, I do get feedback but it there is lots of noise and it seems I’m only able to use the system microphone. I can’t hear the feedback when I’m recording, but only when I have record enabled in the audio track, the top bar, and press play, am I able to go back and listen to the output. I tried exporting the output and it was decent, but I’d still like to get my headphones. When I have my system audio enabled the Speaker and PCM bars in alsamixer immediately go all the way up , with nothing else changing except for the master audio, which goes up as I increase the volume. When only using the headphones the only bar filled is Mic Boost

What I’d like to know is how I can get the audio playback from my microphone audible in my headphones while recording like in Ardour 6 Quickstart (recording, editing, mixing and exporting) - YouTube

Ok so what microphone are you using, and and how is it, and your headphones, plugged into your system?

It sounds like you may be trying to use a USB microphone with headphones plugged into your built in sound card, which is generally not recommended.

   Seablade

I’m using the microphone on a Sony WH-1000XM4 headset and the microphone seems to only connect when either bluetooth is set to ‘Headset Head Unit(HSP/HFP)’ where it’s treated as separate from the system microphone, or as plugged in, where they’re seen as the same. I’m ‘PulseAudio Volume Control’ to get this information.

I tried recording with both of those enabled and neither produced or showed any audio feedback in ardour.

And, a more applicable question in my case: how can I record system audio in ardour?

That is a bluetooth headset. Unfortunately most distributions only support bluetooth with the PulseAudio sound server, but Ardour does not support recording with the PulseAudio backend.

I believe (but am not positive) that the new Pipewire audio server will support Bluetooth devices, but Pipewire is still relatively new and not widely available outside of Fedora Linux, so depending on what distribution you are using it may be a lot of work to get Pipewire installed and configured in place of PulseAudio.

There is an alternate way that may work, although has higher latency (may or may not be a problem for what you are doing), and is known to have audio dropouts fairly frequently.
You load the PulseAudio jack-source and jack-sink plugins, then start jackd (JACK audio server), and configure PulseAudio to use the Bluetooth headset as the audio system, and set jackd to use either a different audio interface (if you have one), or the “dummy” backend.

The convoluted method using the jack-sink and jack-source plugins described above will work for that as well, let the system software use PulseAudio as the audio server, connect Ardour to the jackd server, and connect the ports from the PulseAudio plugins to route where you need.

The Pipewire audio server should be able to replace the combination of PulseAudio and jackd, but again depending on which distribution you are using it could be relatively easy or very difficult.

According to this link I just found Ubuntu 20.04 does have Pipewire available, although you will probably want to use the alternate repository described there because Pipewire has been going through a really rapid cycle of bug fix releases recently:
Install pipewire on Ubuntu 20.04