Can't record internal Ardour midi synth, do hear the sound

Newbie in world of DAW. Hope this is good place for this question:

Use Ardour5 on Linux Mint. Have a project going, succesfully recorded some guitar tracks, as audio via Focusrite Solo. All good. Wanted to add a bass line, so I did:

  • add new MIDI track
  • selected device Midi, Novation Super BassStation.
  • using the “keys” in the track view, I can hear the bass sounds and play along with the other tracks.

But if I arm the new Midi track for Recording, and again play along with the other tracks while recording, I can still hear the bass sound, but nothing is actually recorded.

Have tried to fiddle around with the input and output device settings for the track bass synth, but could not figure it out. Sometimes the red “feedback” indicator lighted up, and I could then change the setting back to stop the feedback, but never to record the sound.

Thanks very much if you can direct me to the right setting. tnx, Pieter

Something that wasn’t clear in your post: are you using the vertical “piano roll” keys on the MIDI track to try and input MIDI data? If so, AFAIK that won’t work. That feature is more or less for auditioning and reference - not for input.

What do you have selected for the bass track’s input & output? The input device should be whatever port your midi controller’s MIDI OUT is attached to. The tracks output device should be the port the sound generator’s MIDI IN (in your case your Novation Super Bass Station) is attached to.

If you do not have a physical MIDI controller, I believe you can use Ardour’s Virtual MIDI Keyboard to input MIDI data, or you can manually input notes using the draw or internal edit modes for that track.

Lastly, what does your Channel Selector setup look like for that track (what I/O MIDI channels are enabled)?

Oh, and welcome to the fold!

Thank you very much! Yes, I was using only the keys on the Midi-track, and so now I know that’s not meant for recording.

I do not have a physical Midi controller, so will try to figure out how to use the Virtual Midi Keyboard.

Right now, trying to answer your other questions re input and output and Channel selector, but Ardour5 is crashing almost immediately after starting it up. Also in ’ safe’ mode, withoug plugins. I’ll return here after restarting the whole computer… :slightly_frowning_face:

The current release of Ardour is 6.9. Please try to stop using Ardour 5.x and use a version with the hundreds or thousands of bug fixes that have already been implemented.

Hi Paul, I am not only a DAW newbie, but really also a Linux newbie. The way I know how to install software is: from Linux Mint go to Software Manager, in the search bar type in Ardour and install the result find. Does that mean the latest update is not in the repositories set in my linux distro? I’ll try to figure that out to, starting with removing Ardour5, I guess. Thanks, Pieter

You do not need to remove Ardour5.

The only officially support builds of Ardour are from Get Ardour | ardour but we charge for those (any amount starting at US$1). You can parallel install those builds with each other and any from your Linux distribution.

It is almost unconscionable that a Linux distribution does not offer Ardour 6.x at this point. Double check that Mint does not make it available under a different name (e.g. “ardour6”).

Never mind, found it! (Slightly different name, anyway: installing. Thanks, P

Hi Paul, still working on installing the latest Ardour. Have now subscribed and downloaded from ardour.org. I have now followed all the steps in the Ardour manual:

  Follow these steps to install the latest version of Ardour:
  
  1. Download the latest release from [ardour.org](https://community.ardour.org/download).
  2. <kbd>Right</kbd>-click the downloaded file and choose properties.
  3. Click the Permissions tab and check the option "Allow this file to run as a program".
  4. Close the dialog and double-click the file.
  5. Follow the prompts.

Now the script is running and warning me of this:

Install Harrison XT plugins and ACE plugin GUIs? [Y/n]: y
Deploying Harrison plugins to /opt/Ardour-6.9.0/lib/LV2/Harrison.lv2

Checking to see if Jack is installed

Jack already present

Jack Version Check OK (jackdmp version 1.9.12 tmpdir /dev/shm protocol 8)


System failed the quick sanity check... Looking for the cause

!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency.
For best results turn it off, e.g. by choosing the 'performance' governor.

Can you advise/direct met how to choose the " performance" governor, I don’t know what it means?

Thank you very much, grtings, Pieter

Short version:

sudo cpufreq-set -c1 -g performance

Note that according to this thread: set cpu permanently to performance governor in 19.1 - Linux Mint Forums
This seems to max out the CPU in general and keep it there for at least some Intel processors. Not a problem on the desktop in general depending on your views on power usage and cooling capabilities of your machine. This would likely be most important during recording to prevent dropouts, or if you are having issues with dropouts on a regular basis. You may want to try with non-critical material first leaving it on the standard setting though for the moment and see how the performance is for you.

   Seablade

Thank you, I’ll first try without changing that setting and see how that goes first.