Can't record, but can monitor myself

Hi, I’m running ardour over alsa (no jack or anything running)

I can go to “mix”, right click that funny 12 button (I have no idea at all what this is supposed to be)

and set it to

image

and I can hear myself.

But I have no Idea how I can get my signal to be recorded into my track. No clue at all. I have ticked the red circles for recording on both the track and the top left, and it has worked in the past. but there is no signal being recorded anymore.

I wonder why. I selected a single audio source when setting up alsa when starting ardour, why would it not just use that by default and randomly break?

Right click the track → inputs → Hardware → connect "system"4 with your track

I know ardour is a huge project and quite impressive overall. But I’m so incredibly frustrated at this point. I hate using my computer so much and try to avoid it at all costs exactly because of stuff like this. Because audio in linux is ALWAYS a nightmare and NEVER plug and play. I just want to record myself. Why can’t I just record myself? I just wanted to record a few things for my lesson tomorrow but no, lets struggle with getting my sound to work for an hour. Why can’t I just have fun once with my computer.

None of this behavior is the default for Ardour.

The default behavior would connect the inputs from your hardware to each successive track (in round-robin order). Each track would have its outputs connected to the master bus inputs. The master bus outputs would connect to the first (two, typically) outputs of your hardware.

The screenshots you’re showing, particularly the first one, show the somewhat classic hallmarks of a new user who just got started, has something slightly odd about their setup, starting trying to rewire things, and ended up so far from “normal” that nothign really works.

Thanks. How do I restore the default behavior? I have to wire the input to each individual track by hand each time now

Fixing up an existing session is more complex. It frequently makes more sense to just start over, unless you’ve already recorded critical stuff into this session. But before you do that, check in Edit > Preferences > Signal Flow to make sure things look like this:

image

If there is nothing in this session and you don’t know what you did, you may as well delete it and open a new one.

Now you should learn a bit about how routing works in Ardour, maybe check this out: How to manage connections in Ardour. Ardour is a complex software that performs complex tasks, this comes with some learning curve.

When you add a new audio track, Ardour will automatically select an input as Paul already explained, however that might not be the one you want depending on which input of your audio interface you are using. It is normal to select by hand which input you want in many cases as default behavior doesn’t suit every use, and it really can’t.

Mine looks similar:

image

I’ll check that video out soon, thanks.