Cant open my session

I have a session that i have finished and i have already exported it once, but the gain was too low. I tried to open it again and it will not open and gives me some error messages instead.

I am using ardour 2.8.14 on linux mint debian (lmde) and the errors i get are to do with JACK ports, but i have those set to 1024 in the qjackctl options. Here is the error message i get in the little box that pops up:

AudioEngine: cannot register port “Audio 26/out 1”: No more JACK ports are available. You will need to stop Ardour and restart JACK with ports if you need this many tracks.

the ardour-log window has multiple errors such as “cannot create region from XML” and “XMLNode describing audioregion references an unknown source id = 43730” but it wont let me cut and paste it and i dont know where the log file is located, so that would be something I would like to know.

I have put the project file on my website so you all can have a butchers

I tried to edit the project XML and remove references (whole chunks) to the offending numbers in the ardour-log window but I didn’t really know what I was looking at so it didn’t work. Is there a reference anywhere to the way ardour builds up project XML, because i’d like to read it if there is.

I have already reconstructed this project once and I don’t have the strength of character to do it again for the sake of adjusting some gain levels for export, please help me.

i am not trying to be rude, but what do you expect to happen when you post this on a forum? do you find this to be a good medium for report problems and asking for help?

it will be vastly easier to help you if you report this sort of thing on a mailing list or get on the IRC channel so that people can actually interact with you in more or less “real time” rather than via this (terrible) medium …

Sorry mate, I didn’t know where else to turn. Can you post some links for me so I can find these places of which you speak? usually a forum is a good place to find help, or so I have found in the past when i have had other issues with different things so yeah, I do think its a good medium to report problems and ask for help.


See the ‘support’ link on the top of the page for info on the mailing lists and IRC;)

Paul is right, this problem is much better off solved in IRC. I can tell you based off what you posted the unable to reconstruct regions is not likely to be the cause of the crashing session. Instead it is far more likely to be the jack port issue, and that will take some more intense troubleshooting most likely given that you already raised the limit.

thanks Paul and seablade, you’re right actually i signed into the irc earlier on and i got a great response, so i’m very happy. My problem is not yet resolved but i’m sure it will be. i am going to upload the project somewhere for paul to have a look at, it is a weird problem and i hope it can be sorted out. i will be sure to make a donation to ardour soon too, coz to be honest when windows crashed (when i used to use it) Bill Gates didnt stop what he was doing to help me so i really cannot have any higher praise for ardour support at this time.