Can't open any project

After Ubuntu Studio 14.04 was released, there was a problem to open old projects. Now in 14.04.1 and Ardour 3.5.403 nothing changed.
I just try to open project with minimum plugins and without content (template for drums). And i got errors.
Segmentation fault (core dumped)
Error in `/opt/Ardour-3.5.403-dbg/bin/ardour-3.5.403’: double free or corruption (fasttop)
fftw: planner.c:261: assertion failed: SLVNDX(slot) == slvndx

There is Ardour’s full debug log:

I use Calf and TAP plugins.

Almost certainly caused by your use of CALF plugins that are using a library that is not thread safe. There is a new version of CALF in their git repository that has a workaround for this, and there is a bug report filed against libfftw that is discussing the deeper solution. This is not an Ardour bug and we cannot offer a workaround. You can restore your session(s) only by editing one or more of the CALF plugins in use. If you need help with that, find us on IRC.

Actually, not even their git repository. CALF fixed this in December 2013, a few days after Ubuntu’s 14.04 freeze cut off. Any newer release of CALF will also fix the problem in the version you have.

Ok, compile from git:
Nothing changed.

We have been told that CALF fixed this issue. Your crash has every hallmark of crashing in the middle of the FFTW planner routine, which is known to be non-thread safe. CALF’s developer informed us that they had worked around their use of this.

Another approach to “fixing” this is to tell Ardour to use only 1 CPU for DSP. This has downsides, however.

New CALF has different setup directory! I didn’t delete old version.
Now all works fine!

Hi, I’m experiencing the same issue.

I recently installed Ubuntu Studio 14.01, dumbed the originally installed Ardour 3.5 to the latest version.
I’ve finished a project in which I was using CALF plugins, but now I can’t reopen the project straight on.
The only work around I found for now is to manually deactivate the plugins by editing the .ordour file.

Having read this thread, I compiled CALF from git. But I don’t know how to remove the previous calf version (if I should) and how do I setup the newly compiled version.

Any help would be appreciated.

Solved it, thanks anyway