Can't open a session file (hangs up at plugins)

I’m attempting to open a session that I haven’t opened in a since November 11th, and Ardour hangs up at “Setup signal flow and plugins” (the box in the center turns gray and non-responsive). It’s really important that I am able to open this session file. Is there a way to perhaps disable the plugins used or remove them all and then open it (I don’t know it looks like the plugins are the issue)?

Thanks in advance and thanks for all of the hard work on this awesome DAW!

Hi Peter7K,

you can start Ardour from the console with “ardour2 -d” (disables all plugins). If that doesn’t work, you could upload the session file and post it here (audio is not needed), so we could have a look at it.


Drat… it still hung up at the exact same spot…

Edit: here’s my project:

I can’t unpack that zip file. Can you post just the .ardour file somewhere?

Won’t it not have all of the samples? Here it is:

Yep… ardour 2.8.11
(built from revision 7387), the one in the ubuntu repos

I tried downloading the full session again and it worked this time … but unfortunately the session loads fine on my machine. I take it that you are using Ardour version 2.8.11?

Hi Peter7K,

I’ve just talked to Paul and cth103 in IRC. We found out that it has probably something to do with jack2. For me, the session works with jackd1 but not with jackd2.
So a workaround would be to install jackd1 (if you are running jackd2). For me in Debian it’s simply “apt-get install jackd1” but you should check twice that nothing gets removed or weirdly reconfigured.


Awesome! You guys are the best. (I suppose I should have just asked in the IRC channel) I wonder if it’s possible to open it in jackd1, close jack and reinstall jackd2, and save it? I will do some testing… Thanks for the help.

Unfortunately it won’t let me connect to jackd2 after opening under jackd1 but it seems to work fine under jackd1 so thanks!