can't open 5.4 file in 5.6 or 5.8

I have an ardour 5.4 project which I can’t open in 5.6 or 5.8. I recently went from Ubuntu 14.04 to ubuntu studio 17.04, so I don’t have ardour 5.4 anymore on the old OS. I can start a new Ardour file in 5.8. There is now a desktop configuration file which also won’t work: Failed to execute child process “/usr/bin/ardour5” (No such file or directory). Any suggestions?

Is it possible to install 5.4 on the new system till I figure this out?


Your .desktop file is likely looking at the wrong place. If you installed Ardour from this site it should be a path like /opt/ardour-5.****/bin/ardour5

If you open Ardour5 from the command line and then open the session, does any text appear on the terminal?


First I start Jack. Then:

adam@leno:~$ Ardour5
bind txt domain [gtk2_ardour5] to /opt/Ardour-5.8.0/share/locale
Ardour5.8.0 (built using 5.8 and GCC version 5.2.1 20150903)
ardour: [INFO]: Your system is configured to limit Ardour to only 65.536 open files
ardour: [INFO]: Loading user configuration file /home/adam/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel® Core™ i7-2670QM CPU @ 2.20GHz
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Loading default ui configuration file /opt/Ardour-5.8.0/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/adam/.config/ardour5/ui_config
Cannot xinstall SIGPIPE error handler
Color shuttle bg not found
ardour: [INFO]: Loading color file /opt/Ardour-5.8.0/share/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.8.0/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.8.0/etc/clearlooks.rc
Found nothing along /home/adam/.config/ardour5/templates:/opt/Ardour-5.8.0/share/templates
run dialog
curl failed: No Error

If I try to open the old file, the program simply closes without any messages. It will open the old file in safe mode, but then I can’t really work on it with plugins. Before, the program would make a backup of the old file for the old Ardour and open a “new” version with the updated Ardour. I tried changing the Ardour5.desktop to the correct path in /opt, but that didn’t help this problem.
What should I try next?

If it will open the old file in safe mode with no plugins, then it sounds like the most likely issue is with one of the plugins. The next steps are to make a backup of the original file (VERY IMPORTANT) and then go through and remove plugins one by one in the XML until it will open the file.


I found the first example of calf… and commented it and the following info out with <?ignore ... ?> and then I got this:
“This session contains the following plugins that cannot be found on this system
Calf Equalizer 8 Band
Calf blah blah
Those plugins will be replaced with inactive stubs. It is recommended that you install the missing plugins and re-load the session. Also check the blacklist, Window > Log and Preferences > Plugins.”
I haven’t found the blacklist yet. Synaptic said the calf gear was installed, but I reinstalled it anyway. Still no luck.
I never used Ubuntu Studio before and it automatically installed Ardour 5.5 without going through your website. Maybe it set up something wrong. However, I am pretty sure I purged that version before downloading the 5.8 from Do you think there is some simple link to the calf gear that is broken?
Many thanks,

Ahh Calf plugins… enough said sadly.

They have been known to cause issues, make sure you have the most up to date possible version, and that likely isn’t available from Ubuntu Studio’s repos is my guess.


I just stumbled over the very same thing. Did an upgrade to 17.04 recently and couldn’t load my projects any longer. I have upgraded my calf-plugins to those from KXStudio, that did the trick.

In the meantime, how can I download an Ardour 5.4 version? Hopefully that should do the trick.
Of course I will try the newest calf plugins, can’t do it till the morrow.
Thanks till the next note.

Hmm. i downloaded the kxstudio repositories and reinstalled the calf-plugins. Trying to load the old file resulted in a loud high tone. Also the new file I started doesn’t load the calf gui, only the generic gui. Somehow one would think installing ubuntu-studio would take care of all that.
Is there any way to atleast install Ardour 5.4 and try from there again till I figure this out?
Thanks, Adam

We do not make old versions of Ardour available. It can be built from source if someone really needs it.

You should really avoid using the CALF plugins. When they work, they work. They look nice. But they are one of the most consistent source of problems/errors/crashes for all Ardour users on Linux.

That’s too bad. I will see what I can do with other plugins. Thanks

I have the 64 bit version of Ardour-5.4 install package.

Paul / Developers: Is it ok to share this old version of Ardour with one user to help out with his problems ?

@mhartzel: GPL (Ardour’s free software license) says you can do whatever you want with it.

adamw: here is Ardour 5.4 64 bit, gcc4:

@adamw. Take a look at

Hi, thanks for the help. I suppose one could say I cheated, because I saw that avlinux had a brand new version out, so I thought I would try it. In any case, all the calf plugins work. I did download the 5.4 for safety reasons, just in case. It took me awhile to get used to the Debian system after easier ubuntu. Till the next question,