Can't make ardour play all my project

Hi, this is a newby question. I was working in a specific track, so I soloed it. I started looping a specific region from that to listen to that part of the sound while adjusting an eq parameter. After that, when I became satisfied with the result, I deleted the loop markers and unsoloed the track. Than I hit spacebar to play all my music. After that, Ardour behave in an odd way: it just played to the point where the loop marker used to be; then it stops, and I have to hit space again if I want to listen to the rest of the song. What is that? How do I fix it? I am using Ardour 6.7.0 on a Ubuntu Studio 20.04. Thank you.

This is unusual, perhaps you’ve also moved the “End” marker and have

Preferences > Transport > Stop at the end of the session


I can’t say for sure that this is exactly the OP’s situation, but I think it is related on how the loop is created. Here is how I can reproduce it:

  • Set playhead Auto Return on.
  • With the range tool, select some range.
  • Set loop the range with ].
  • Play loop a few time.
  • Stop playing. (Playhead goes to beginning of the loop.)
  • Start play again.

Playing will stop at the end of the loop. The “problem” is the selected range, it seems. It plays the range while it is still selected. Moving the playhead from the beginning of the range (or “deselecting” the range) makes it play as normal.

Thank you Robin and Luis. I have tried both suggestions but none actually worked. I’ve made a 37 seconds video and uploaded it to youtube. If you please check it there I will be greatful.
Thanks again.

Any automation or plugins that might dis-engage at that point?
Are there any control surfaces enabled (preferences > control surfaces) that may trigger this.

I’ve never see anything like this. Can you share the .ardour session file? perhaps on that may shed some light.

It is possible to write a Lua script or use a plugin to stop Ardour’s transport depending on some conditions, but you’d have to explicitly add those.

Thank you very much and sorry for tooking a long time to answer. I am sending the zip file of the project. Thanks a lot.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.