cant load files

Really pleased and happy user here.
Yet, I reinstalled my system (found a larger harddrive for my laptop) and everything is pretty much working. But not all old projects. I can open old projects without missing files, but the ones with missing files refuse to open, even if i locate the files, it promts again. With “skip this file” I get “did not load successfully: Cannot configure audio/midi engine with session parameters” .
Have tried fiddling around with differnent buffer rates and stuff, but it all should be good, since other projects run fine without missing files.

i found this bug reported which seems similar

I have ardour 5.4.0
Does the bug remain?

Any ideas?


Can someone explain what
"It might be easier to amend dbf86a495b8 and simply remove “must_exist = true;”
( line 149, if (Glib::path_is_absolute (_origin)) …)

It’s unclear to me under what conditions is must_exit == false with an _origin set and why the file is required to exist in that case, so I special cased the c’tor instead for SilentFileSource. "

means? - this has meanwhile been fixed

oops wrong url

But its still the same problem for me.
I have 5.4, not 5.4-103
I’ve paid once, but I’m not a subscriber, and don’t have access to nightly builds.
Is it something i could fix myself?
What and where is the "dbf86a495b8 to simply remove “must_exist = true;” ?

Those IDs refer to source-code changes. (Ardour5.3-56) introduced the problem. Ardour 5.4.0 is affected. (Ardour 5.4-103) fixes it, and Ardour 5.5 will be fine again.

Meanwhile you could edit the .ardour session file, find the <Source … origin="…" > of the the missing file and remove the origin.

Awesome! That did the trick!
thank you so much! =)