Can't import music...

I just installed Ardour GTK2 the first time. Fortunately I somehow managed to connect the JACK audio Server with Ardour, but now I got some trouble importing music. When I press alt+i (or in the menu “session” - “import”) I only see some options (which I can’t change) but no browser and nothing to find a file I want to import. Is this a bug, or maybe there’s a package missing? Maybe re-installing help?

But I’ve another question: Is it possible with this program to cut music (classical mostly) as well to reach the quality level of a CD? So well, that you can fade out before you cut and fade in again after the cut and that there is nothing left like a click, a change of sound, or anything like that. I’m looking intensivly for such a program, though I have much to do with recording music and this would really be a great thing…

Ok, see you.
Best regards

If you don’t see some thing like this there’s something really wrong with your ardour install.

Oh, wow!
It really worked, I’m very happy! I just had some problems compiling; entering “scons -j 4” made some errors but I found out that a package was missing and installing that solved the problem…
Anyway I really thank you a thousand times,
Best regards,


maybe this would help you a bit :

  • open a terminal
  • optionally, if you installed ardour from your package manager, remove it: sudo apt-get remove ardour
  • cd to a directory of your choice with enough space. My own ardour source tree, when compiled, amounts to 507MB :wink:
  • now type:

sudo apt-get build-dep ardour

This will download all the dev files needed to compile ardour

  • then check out the source code :

svn co ardour2_svn

This will create a directory called ardour2_svn (you can call it something else if you want) with all the latest code. If you prefer, you can download the tarball corresponding to the 2.7.1 release from the ardour download page.

If you don’t have svn installed, just install it: sudo apt-get install subversion
And then check out ardour.

  • cd into ardour2_svn and type the following:


If you happen to have a dual or quad core CPU, type

scons -j 4

In my DAW, I have a Core 2 Duo CPU 2x2.4GHz and 4GB RAM. It takes 13mn to compile with scons -j 4

When things are compiled, type

sudo scons install

This will install ardour in /usr/local/bin and will be called /usr/local/bin/ardour2
You can now try to launch from the terminal. If it works, you can make an icon on your desktop that points to it so you just have to click to invoke ardour2.

One thing you may also do from the terminal before launching your newly compiled ardour is to remove or move the .ardour2 directory since stuff may have changed in there :

  • open terminal
  • cd
  • mv .ardour2 .ardour2_old

Then launch ardour2. No need to move this hidden directory after that. But as a rule of thumb, do it when you upgrade ardour.

Yes, that’s exactly my problem… Thanks for your answer!
As you already said, there would be no way for me of compiling Ardour myself, though I am not only a new Ardour user, but quite new to Linux and therefore programming as well. But maybe I could manage it, if someone gave me really detailled instructions? If you have the time, this would be something really interesting to me; I never did such a thing before…

If it’s really not possible for me, even with your best help, then I’ll try installing some other Linux. I’ve now Ubuntu 8.1 running, with GNOME; I’d going to try OpenSUSE or Fedora, possibly even a KDE Desktop on Ubuntu would fix it… We’ll see.
Anyway thank you a lot for your help.
Regards, Renua

Several linux distributions have, somehow, built versions of Ardour in which the import dialog is made completely useless. I am sorry that you have encountered this issue. Please complain vigorously to your distribution package managers. The problem goes away if you compile Ardour yourself, but I understand that this is beyond the grasp of many people testing Ardour for the first time. I wish there was a way for us (people involved in the development of Ardour) to fix this, but sadly, there is not. I do not know what the people who built these broken packages did, but it is very unfortunate and unfair to both us and potential Ardour users.

Hi, I seem to be getting same problem on Xubuntu too…i’ll give this a try when I get a chance.

Cheers thorgul, this actually worked for me too! Nice one.

great to see that my little recipe is helping you guys :slight_smile:
When you get the hang of it, it really is a routine to upgrade ardour from source. The dependencies don’t change much over time so you can skip the apt-get build-dep step and all you have to do is :

cd ardour2_svn

scons -c (or sudo scons -c install, which will also remove the old installation before removing the object files from the source tree but read my advice at the bottom of this post before considering uninstalling)

svn update

scons -j 4

sudo scons install

It takes 15mn in all (at least on my system).

One advice: before you install, enter the ‘gtk2_ardour’ directory from the ardour top dir and try ./ardev :

cd ardour2_svn/gtk2_ardour

ardev is a little script that allows you to run a custom-compiled ardour that has not been installed. Just to make sure that your updated ardour won’t break your older installation. Simple safety measure.

yep…also on Ubuntu 8.10
and no file navigator windows
just the row of pull downs along the bottom:
‘Add Files’…etc
I work around this by dragging files directly into Ardour

Hi, I had exactly the same problem - running Ubuntu 8.10 and couldn’t see the import box properly.

Tried the fix above and amazingly even given my novice skills, it worked perfectly. So thank you!

There is a work around for this, at least in Ubuntu. You can drag a file directly from Nautilus into the Ardour editor window and drop it. It successfully does the import. That’s actually easier IMO.