Can't hear the metronome

HI,

I have an issue with Ardour 3.5.308: I can’t hear the click (metronome).
I toggled on the big green metronome button in the transport bar;
I selected a wav file to be used as click sound, and set the gain.
I plugged all the jack cables… but i still can’t hear the metronome.
I tried to route the click to a bus, but it seems like it’s disabled (see the picture).

https://drive.google.com/file/d/0B_As8UFt_sXUOG5HM0ZwZjd2ZTQ/edit?usp=sharing

can anybody help me?
Thanks
Michele

Ive just created a new session just incase its a bug that has popped up again (this happened in a previous ardour version and the solution was to create session in an earlier version and open it up in the new version)

Metranome is working for me though.

The metranome should work without loading a wav file. have you tried it without?

I just checkied my patchbay and mine is not greyed out like yours so i dont know why it is. i can route the click to a bus. But you shouldnt need to do this as the click should be routed to outputs already.

I don’t need a wave file for the metronome, maybe try unsetting the wave file as veda_sticks suggested.

You do have sound in general, right? It’s ONLY the metronome you’re not hearing?

Wowwowooww … same here. I just started Ardour (Version Ardour5.12.0, Kubuntu 18.04) and created a new session. All the Tracks are working fine with jack (means they are hearable). BUT the metronome is not working and also (unlike older ardour versions) I cannot connect the “Click Out” to “Hardware out” (or any system out). Seems like a bug.

I then started an older version and suprise suprise the Click Out had its two channels which I connected to system out. Strange behaviour.

Metronome worked fine for me on 5.12 on Ubuntu Studio 18.04. I’ve moved to 19.10 since then, but I never had such an issue. Is the “hardware out” greyed out if you try connect other audio sources to it? I’m assuming not, it seems like you can hear what you’ve recorded. Did you start the project with the option to automatically connect tracks to soundcard’s inputs and outputs?

Yeah i can hear all the tracks and everything isi connected perfectly. The Click Out is greyed out when using Alt+P, there is no possibility to connect it to either channel.
I created the project via the ardour starting interface after firing up jack with qjackctl…(Also within qjack the click is not recognized or shwoing up)…

Strange. One more question… is there a reason you’re using Jack? ALSA is fully capable of doing anything in Ardour and I think its actually suggested you use ALSA as long as you aren’t using other software that you need to feed in and out of Ardour.

I mean that the correct path to click out is to the master, if jack can’t handle this channel may be is for a good reason.

I use Jack (qjackctl) with the Behringer X32 for multichannel recording and doing all kind of stuff, where it is required to cable up multiple devices. As far as I know alsa is not as capable as jack but maybe I am outdated on this :wink:

… I just did a quick try also with alsa and the problem ist the same: See this picture:

The metronome is not heard but all the other tracks are working as expected…

In comparison when opening an old ardour session the two channels of the metronome show up and everything works as expected:

Same here, all tracks and buses are correctly routed and sounding… but I can’t hear the metronome, and the boxes are also grey in the routing grid…

I’m on Ubuntu 18.04, Ardour 5.12. I do need the jack in the middle because I’m using Guitarix to feed processed guitar sound into several tracks.

Any help will be much appreciated. Best

I can confirm the same issue, using Ardour 5.12 with Alsa under Ubuntu 18.04. The “click” connections to the master bus or any other bus are grey, no connection is possible.

Ardour v6 has been released, try that and see if you still have the same problem. Make sure you test with a package from this website to eliminate packaging issues (Which have been a problem in the past on Ubuntu)

     Seablade

I was having the exact same issue as described (I was running Ardour 5.12.0 from the Debian 10 (Buster) repositories). What I saw resembled Benjamin10’s attached screenshots exactly: “Click out” appeared as a row of greyed-out cells in the connection matrix.

I purchased and installed Ardour 6.3.0, and re-opened the exact same project (thereby migrating the project file to 6+), and the problem is now fixed! L and R “Click out” was automatically connected to “Master in” after I migrated and opened the project in Ardour 6.