Can't get MIDI notes to register

I’m using Ardour 5.9.0 and setting up with either Qjackctl and ASLA (they both have the same problem) under Ubuntu 16.04 LTS.

I can draw the midi notes, play the notes using a virtual instrument and get sound, but when I record the notes they are not being written.

I’ve ran out of ideas with this so any fresh ideas from someone else are welcome.

Does the MIDI track have the “Enable/Disable Midi Input” button (on track mixer strip) enabled (set to green)?
Have you connected your midi device to the track (Midi input button and select input with Routing grid)?
If both the the above are done then when you play your keyboard you will see the midi input bar move on track mixer strip when you play your keyboard.
If this works to record enable the track record button, the global record button, and click play.

Yes it is green.

I have no clue about the second one since there’s so many options, but I have tinkered with it for about 5-10 hours and have given up. There’s MIDI oscillators and clocks too, I don’t know if this has anything to do with it.

The midi input bar moves, there is sound, but nothing is being written into the track. I’ve used both the global recording button and the track recording button. Maybe my best bet is to post a screenshot of my connections.

How are you recording notes? Hardware keyboard thru MIDI?

ZynAddSubFX virtual keyboard or General MIDI virtual keyboard. I also use the keyboard that’s built into the track when you enlarge the track section.

Sounds to me that you have not set up a MIDI input to your track which is done with the “Midi input” which is next to the “Enable/Disable Midi Input” button.
First of all ZynAddSubFX virtual keyboard does not have a midi out so you cannot record midi from that. I’m not familiar with the “General MIDI virtual keyboard” but it it has midi output it should be visible on the QJackCtl connections panel under either the “Alsa” tab (meaning it outputs to alsa midi), or on the “MIDI” tab meaning it outputs to Jack midi. Since Ardour uses Jack midi you’ll need to run a2jmidid which will make Alsa midi devices visible to Jack midi under “a2j” in the QJackCtl MIDI tab. Once you identify the midi output of “General MIDI virtual keyboard” in QJackCtl you can connect to the Ardour track with the “Midi input” button. Click “Midi input” and select “Routing Grid”. In the routing grid select “Other”. You should see the “General MIDI virtual keyboard” (which might be listed as “a2j” if you are using a2jmidid). Click the box for your keyboard input and then you should be able to record to the track from it.

1 Like

As said by Edward, not sure that you’ve got a working setup. Maybe you can find a way here:
http://libremusicproduction.com/tutorials
HTH;

I have the same issue. I don’t have a physical midi instrument, but using the keyboard that comes with the MIDI track.
If I “draw” each midi block in the drawing mode, I can then reproduce that. But if I click on the piano notes (which produce sound) while recording the midi track, nothing gets recorded. I expect the midi block notes to get filled, so then I can see what I have played manually with my mouse.
What am I missing?

See here:

Short version, I assume you are using the vertical keyboard in the track header, use the actual virtual keyboard window instead or a different virtual midi keyboard if you choose.

   Seablade
1 Like