Can't get microphone input to work


I am running Ardour 2.1 in JAD 1.1 (JAD 1.1 is a digital audio hack of openSuse 10.3) on an Acer Aspire 3680-2682. The soundcard as indicated by lspci is: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02).
JACK is running in Duplex mode. I had it configured in playback only and realized I should change it.
I tested the mic with an amp to verify that the mic is working and that the cables are good.
In the online manual, it talks about using a software mixer. I have more than one mixer installed. one is JACK aware but very limite. The others are ALSA mixers. I am unclear as to whether one that is JACK aware preferable to one that is not. The JACK aware mixer does not seem to recognize all of the sound channels.
Any thoughts on what I ned to do to get he mic to work? Thanks


I have my system dual booted with Ubuntu Studio (8.04) I tried it in Ubuntu with the same result. I also tried recording to Rosegarden and Audacity. That was a no go as well.

you do not want a “software mixer”. you want the software that controls the hardware mixer on the card. the generic version of this is a terminal utility called “alsamixer”. this will let you:

a) select the mic input as the capture source
b) enable or disable any mic gain boost, as appropriate

please read up on alsamixer. there are other apps that do the same thing; alsamixer is almost certainly already installed on your system.

it is important to realize the consumer audio interfaces, like the one you have, only allow capturing from a single input source (mic, line in, whatever) at a time. hence the problem you are having. it is also important to realize that using microphones with this class of audio interface has lots of other potential problems too, particularly with sound quality. you should read up on pre-amplifiers, microphone gain and line levels.

Hi Paul,

Thanks for the help. I just got things working. There were some input/output choices in ALSA that were peculiar to my machine/sound card that I didn’t have set correctly. There was a “Front mic” input and and a “mic” input. I mistakenly thought the “front mic” was the external mic input and the “mic” was the built in “mic” when it was actually the other way around.