Can't get Delta 66 to work... I'm really starting to hate jack :-(

Disclaimer: I’m REALLY frustrated about this. When I tried to get the on-board card to work with jack, it was a pain (although I eventually got it to work after some guessing game). I had to again do some guessing with jack to figure out how to get an M-Audio Transit going. Now I’m trying to setup a Delta 66, and AGAIN, it won’t work, however no luck with the guessing game…

Down to the details:

  1. I’m using ubuntu 7.04

  2. The Delta 66 is properly detected

  3. in qjackctl, the card does show up:
    hw:2 M Audio Delta 66
    hw:2.0 ICE1712 multi
    Tried all combinations interface/input device/output device too

  4. I have 4 ins and 4 outs selected

  5. Frames/period: 128
    Sample Rate: 48000
    Periods/Buffer: 10
    And I’ve played with those as well

  6. Yep, I’ve also checked envy24control

List of messages follows.

Some help would appreciated.

14:28:07.755 Patchbay deactivated.
14:28:07.786 Statistics reset.
14:28:07.796 Startup script…
14:28:07.796 artsshell -q terminate
14:28:07.841 MIDI connection graph change.
can’t create mcop directory
Creating link /home/stb/.kde/socket-mino.
14:28:08.063 Startup script terminated with exit status=256.
14:28:08.063 JACK is starting…
14:28:08.064 jackd -v -R -p128 -dalsa -r48000 -p128 -n10 -D -Chw:2,0 -Phw:2,0 -i4 -o4 -H -M
14:28:08.072 JACK was started with PID=12440 (0x3098).
getting driver descriptor from /usr/lib/libjack0.100.0/
getting driver descriptor from /usr/lib/libjack0.100.0/
getting driver descriptor from /usr/lib/libjack0.100.0/
getting driver descriptor from /usr/lib/libjack0.100.0/
jackd 0.102.20
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
server `default’ registered
loading driver …
apparent rate = 48000
creating alsa driver … hw:2,0|hw:2,0|128|10|48000|4|4|hwmon|hwmeter|-|32bit
control device hw:2
configuring for 48000Hz, period = 128 frames, buffer = 10 periods
ALSA: final selected sample format for capture: 32bit little-endian
ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
cannot load driver module alsa
registered builtin port type 32 bit float mono audio
registered builtin port type 8 bit raw midi
clock source = system clock via gettimeofday
required capabilities not available
capabilities: =
new client: alsa_pcm, id = 1 type 1 @ 0x8069780 fd = -1
starting server engine shutdown
freeing shared port segments
stopping server thread
14:28:08.327 JACK was stopped successfully.
14:28:08.328 Could not connect to JACK server as client. Please check the messages window for more info.
14:28:11.614 MIDI connection change.


weird. I use to use a Delta1010-LT until last week (replaced since by RME HDSP Multiface II). I had no problem with jackd and the Delta card. My setting was (after having disabled the onboard chip in the bios which caused alsa to randomly assign id number to each sound card after each boot):

jackd -R -d alsa -dhw:0 -p64 -r48000 -n2 -H

that was all I needed (not even sure -H was needed since the delta had its own h/w monitoring stuff). Note that I used -n2.

Since then, I am using the HDSP system, and my setting is exactly the same (except that I now assign static alsa id to each sound card, which seems to work, no more hw:1 becoming hw:0 at next boot and vice-versa).

Hmmm, please just shoot me. Specifying 0 input port and 0 output port in qjackctrl gets the thing started.

Refer to my disclaimer in my initial post to know how I feel about this.

BTW. I know qjackctl is not jackd.

qjackctl is not jackd, true, but qjackctl is ultimately sourcing a file in your $HOME directory, namely .jackdrc, which contains the jackd setting you had set up in the GUI. If you now type “ps xa | grep jackd” in a shell after you pressed the Start button in the GUI, you will see what I mean :slight_smile:

by the way, I hardly used qjackctl before, so I did not think about the misleading setting (input and output channels). For me, using jackd from a shell is an easier way to find out if jackd works at all.

I understand about qjackctl and jackd (I even had deleted .jackdrc and .qt/qjackctlrc). But, even though I’m not completely stupid :-), I still find that getting jackd is painful.

It seems to me that there are obscure knobs which makes it a bad user experience, such as having to play with frames/period to get some cards working.

Anyways, now things seem to work although I don’t know why I see 12 capture ports and 10 playback ports with a Delta 66. I’m sure there’s a good reason for this…


PS. I love ardour, but it remains a love/hate relationship with jackd :slight_smile:

Re: 10 out/12in … this is the actual physical configuration of your Delta 66. Read the manual.

As for JACK, as I just wrote on another forum thread, we do not want Ardour to become another typical single application ghetto like so many proprietary DAWs. the minute you want to record from internet radio, or broadcast a live session to the net, you will start to understand how powerful JACK is.

Its unfortunate that we do not have a database of configurations that work for every single card. Its maybe even more unfortunate that there are still so many audio interfaces out there that do not accept completely standard configuration requests (e.g. duplex, 1024 frames/period, 2 periods).

QJackctl does have some issues with its user interface in a few minor areas - the channel count issue that you ran into is one of them. Ardour 2.0.6 will have its own audio setup dialog for use instead of QJC that should address these sorts of issues, though obviously it would be nice for QJC to fix them too.

Hi Paul,

Regarding the concept of JACK, I understand it and I think it’s great. My frustration isn’t that I have to use JACK. I’m happy to use JACK… it’s just the bit about getting it to work.

In short:

  • I love ardour
  • I love to use JACK
  • I hate to setup JACK on a new card

I’ll be sure to check out 2.0.6.


Hi, Steph. I know that it is an old post, but I have this problem now.

I have a Delta 66 and I have the problem that you said.
I tried any possible configuration, I suppose.
Jack start, EnvyControl show me some activity. But I can’t get sound from the out port of the Delta 66. I play with frame/periods, sample/rates, period/buffers.
She is still mute. :frowning:

This is my configuration:

CPU: AMD Athlon™ 64 X2 Dual Core Processor 4800+
Memory: 2GB Ram
Distro: 64Studio 2.0
Kernel: 2.6.21-1-multimedia-amd64
Audio: Delta 66(02:07.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02) )

Can you show me your settings.

PD. sorry for my english.

Some suggestions…

Can you hear sound at all, when not using JACK? If not:

  1. Check the “analog volume” tab in envy24control. DAC0 (Digital to Analog) is your output number 1 and so on. Are the ones you are connecting to yur speaker system turned up ? (I put mine at 115, it’s good for me). (The ADC’s are the input levels).

  2. Needless to say the most basic setting for jack is the “interface”. Make sure jack is seeing your m-audio. You might have to change the default to hw:1 or whatever number your system assigns to that card. Do as Thorgal if you don’t need the onboard audio card.

  3. I have an Audiophile 2496. I think it’s got to be similar. I also use 64studio. I’ve got:
    Realtime: Yes
    Priority: 0
    Periods/buffer: 2
    Sample rate: 48.000 or 44100 (44100 is a good choice if you just want to make audio work)
    Frames/Period: 64 (if you’ve got xruns with this setting try increasing this number until you haven’t)
    For the rest in the right column, I’ve got 0 or default.

Also, you can check the manual and search the forums at 64Studio. There are several questions and answers about silent cards.
I hope this helps

Still muted…
I can’t play audio in Audacious if I choose ALSA driver, it return me an error: “the sound card isn’t configured correctly…”.
I don’t know why JACK start without problems(JACK use alsa driver with Delta66), I select JACK output plugin in audacious, connects ports, open Envy24Control and can see that something is playing!
In Windows work well, I know how route the I/O’s.
Already I tried with 64Studio’s LiveCD and got the same problem.

I will continue trying, thanks!

My tip: Don’t start jack until you get the card working.
Audacious: If jack is not active you need the alsa output plugin. If it is, you need the jack output plugin.
As you mention, your issue may have to do with the routing. Check at the patchbay/router tab of envy24control that the H/W outs are set to PCM outs.
Or else… have you read 64studio users’ FAQ number 10?: If you are trying to play a mp3 file you need the right libmad package. Go for it through synaptic.
This post would rather belong to the 64Studio forum. People there are very helpful. So they are here, don’t get me wrong. But this is not ardour related.
Good luck

Muted M-Audio Delta 66…
Well, there’s a bug in ALSA with this revision(E or 02) of MAudio Delta Card.

This is my card:

lspci -v

02:08.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
Subsystem: VIA Technologies Inc. M-Audio Delta 66

This is the ALSA bugtrack ID:

I think that this is important to know for Ardour’s users, 64Studio’s users and Gnu/Linux’s users; the problem is the same.
Isn’t a distribution problem, I have tried with others distros and get the same problem.
Juan Matías.
I still looking…

I have my sound card working!!
I set a diferent model for my Delta66 in /etc/modprobe.d/alsa-base. I put “options snd-ice1712 model=delta1010lt”.

I had recently installed Ubuntu Studio 8.04 Kernel 2.6.24-16-rt

All seems to be equal till I raise up DAC4 and DAC5 volumes in AnalogVolume tab on Envy24Control.
Move DAC6 and DAC7 to.

Juan Matias.